SDUT Time

Time
Time Limit: 1000 ms Memory Limit: 65536 KiB
Submit Statistic
Problem Description

Digital clock use 4 digits to express time, each digit is described by 3*3 characters (including”|”,”_”and” “).now given the current time, please tell us how can it be expressed by the digital clock.
Input

There are several test cases.
Each case contains 4 integers in a line, separated by space.
Proceed to the end of file.
Output

For each test case, output the time expressed by the digital clock such as Sample Output.
Sample Input

1 2 5 6
2 3 4 2
Sample Output

_  _  _ 

| || |_
||_ |||
_ _ _
| ||| |
|_ | ||
Hint

Source

//import java.io.*;
//import java.math.*;
//import java.text.*;
//import java.math.BigInteger;
import java.util.*;
public class Main 
{
    public static void main(String[] args)
    {
       Scanner cin = new Scanner(System.in);
       while(cin.hasNext())
       {
           int[] a = new int[12];
           for(int i=0;i<4;i++)
           {
              a[i] = cin.nextInt();
           }
           for(int i=0;i<4;i++)
           {
              if(a[i]==0||a[i]==2||a[i]==3||a[i]==5||a[i]==6||a[i]==7||a[i]==8||a[i]==9)
                  System.out.print(" _ ");
              else 
                  System.out.print("   ");
           }
           System.out.println();
           for(int i=0;i<4;i++)
           {
               if(a[i]==0||a[i]==4||a[i]==5||a[i]==6||a[i]==8||a[i]==9)
                   System.out.print('|');
               else 
                   System.out.print(' ');
               if(a[i]==2||a[i]==3||a[i]==4||a[i]==5||a[i]==6||a[i]==8||a[i]==9)
                   System.out.print('_');
               else 
                   System.out.print(' ');
               if(a[i]==6||a[i]==5)
                   System.out.print(' ');
               else 
                   System.out.print('|');
           }
           System.out.println();
           for(int i=0;i<4;i++)
           {
               if(a[i]==0||a[i]==2||a[i]==6||a[i]==8)
                   System.out.print('|');
               else 
                   System.out.print(' ');
               if(a[i]==1||a[i]==4||a[i]==7)
                   System.out.print(' ');
               else 
                   System.out.print('_');
               if(a[i]==2)
                   System.out.print(' ');
               else 
                   System.out.print('|');
           }
           System.out.println();
       }  
       cin.close();
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值