Dining POJ - 3281(网络流)

Cows are such finicky eaters. Each cow has a preference for certain foods and drinks, and she will consume no others.

Farmer John has cooked fabulous meals for his cows, but he forgot to check his menu against their preferences. Although he might not be able to stuff everybody, he wants to give a complete meal of both food and drink to as many cows as possible.

Farmer John has cooked F (1 ≤ F ≤ 100) types of foods and prepared D (1 ≤ D ≤ 100) types of drinks. Each of his N (1 ≤ N ≤ 100) cows has decided whether she is willing to eat a particular food or drink a particular drink. Farmer John must assign a food type and a drink type to each cow to maximize the number of cows who get both.

Each dish or drink can only be consumed by one cow (i.e., once food type 2 is assigned to a cow, no other cow can be assigned food type 2).

Input
Line 1: Three space-separated integers: N, F, and D
Lines 2.. N+1: Each line i starts with a two integers Fi and Di, the number of dishes that cow i likes and the number of drinks that cow i likes. The next Fi integers denote the dishes that cow i will eat, and the Di integers following that denote the drinks that cow i will drink.
Output
Line 1: A single integer that is the maximum number of cows that can be fed both food and drink that conform to their wishes
Sample Input
4 3 3
2 2 1 2 3 1
2 2 2 3 1 2
2 2 1 3 1 2
2 1 1 3 3
Sample Output
3
Hint
One way to satisfy three cows is:
Cow 1: no meal
Cow 2: Food #2, Drink #2
Cow 3: Food #1, Drink #1
Cow 4: Food #3, Drink #3
The pigeon-hole principle tells us we can do no better since there are only three kinds of food or drink. Other test data sets are more challenging, of course.

建图:
一点要从超级源点到食物,然后从食物到牛,从牛再到牛,从后一个牛到饮料,再从饮料到汇点。
不能只有一种牛,因为这样的话,就有可能会有重复,比如食物1—->牛1——>饮料1和食物2—->牛1—–>饮料2,就有可能都被选择了。所以拆点建图。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <algorithm>
#include <vector>
#include <queue>
#define MAX 6000
#define INF 0x3f3f3f3f
using namespace std;
struct edge
{
    int to, cap, rev;
};
vector<edge>G[MAX];
int level[MAX];
int iter[MAX];
void add_edge(int from, int to, int cap)
{
    struct edge e;
    e.to = to;
    e.cap = cap;
    e.rev = G[to].size();
    G[from].push_back(e);
    e.to = from;
    e.cap = 0;
    e.rev = G[from].size()-1;
    G[to].push_back(e);
}
void bfs(int s)
{
    memset(level, -1,sizeof(level));
    queue<int>que;
    level[s] = 0;
    que.push(s);
    while(!que.empty())
    {
        int v = que.front();
        que.pop();
        for(int i=0;i<G[v].size();i++)
        {
            edge & e = G[v][i];
            if(e.cap>0&&level[e.to]<0)
            {
                level[e.to] = level[v] + 1;
                que.push(e.to);
            }
        }
    }
}
int dfs(int v, int t, int flow)
{
    if(v==t)
        return flow;
    for(int &i =iter[v];i<G[v].size();i++)
    {
        edge & e = G[v][i];
        if(e.cap>0&&level[v]<level[e.to])
        {
            int f = dfs(e.to, t, min(flow, e.cap));
            if(f>0)
            {
                e.cap -= f;
                G[e.to][e.rev].cap += f;
                return f;
            }
        }
    }
    return 0;
}
int max_flow(int s, int t)
{
    int flow = 0;
    for(;;)
    {
        bfs(s);
        memset(iter, 0, sizeof(iter));
        if(level[t]<0)
            return flow;
        int f;
        while((f=dfs(s, t, INF))>0)
        {
            flow += f;
        }
    }
}
int main()
{
    int n, f, d;
    scanf("%d %d %d", &n, &f,&d);
    int t = n + f + n + d + 1;//汇点
    for(int i=1;i<=n;i++)
    {
        int a, b;
        scanf("%d %d", &a, &b);
        for(int j=0;j<a;j++)//食物
        {
            int x;
            scanf("%d",&x);
            add_edge(x, f+i, 1);//从食物到牛1
        }
        for(int j=0;j<b;j++)
        {
            int x;
            scanf("%d", &x);
            add_edge(f+n+i, f+n+n+x, 1);//从牛2到饮料
        }
    }
    for(int i=1;i<=f;i++)//从源点到食物
    {
        add_edge(0, i, 1);
    }
    for(int i=f+n+1+n;i<=f+n+n+d;i++)//从饮料到汇点
    {
        add_edge(i, t, 1);
    }
    for(int i=f+1;i<=f+n;i++)//从牛1到牛2
    {
        add_edge(i, i+n, 1);
    }
    int x = max_flow(0, t);
    printf("%d\n", x);
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值