917:Knight Moves
查看 提交 统计 提问
总时间限制: 1000ms 内存限制: 65536kB
描述
Background
Mr Somurolov, fabulous chess-gamer indeed, asserts that no one else but him can move knights from one position to another so fast. Can you beat him?
The Problem
Your task is to write a program to calculate the minimum number of moves needed for a knight to reach one point from another, so that you have the chance to be faster than Somurolov.
For people not familiar with chess, the possible knight moves are shown in Figure 1.
输入
The input begins with the number n of scenarios on a single line by itself.
Next follow n scenarios. Each scenario consists of three lines containing integer numbers. The first line specifies the length l of a side of the chess board (4 <= l <= 300). The entire board has size l * l. The second and third line contain pair of integers {0, …, l-1}*{0, …, l-1} specifying the starting and ending position of the knight on the board. The integers are separated by a single blank. You can assume that the positions are valid positions on the chess board of that scenario.
输出
For each scenario of the input you have to calculate the minimal amount of knight moves which are necessary to move from the starting point to the ending point. If starting point and ending point are equal,distance is zero. The distance must be written on a single line.
样例输入
3
8
0 0
7 0
100
0 0
30 50
10
1 1
1 1
样例输出
5
28
0
注意每个样例最后都要清空队列,不然下一次案例中还有上一次案例的数据。
#include<iostream>
#include<string.h>
#include<queue>
using namespace std;
struct node
{
int x;
int y;
int time;
};
int vis[310][310];
queue<node>qishi;
int aid[8][2]={2,1,2,-1,-2,-1,-2,1,1,2,1,-2,-1,2,-1,-2};
int main()
{
int k;
cin>>k;
while(k--)
{
memset(vis,0, sizeof(vis));
int n;
cin>>n;
int x1,x2,y1,y2;
cin>>x1>>y1>>x2>>y2;
qishi.push({x1,y1,0});
vis[x1][y1]=1;
while(!qishi.empty())
{
node z=qishi.front();
if(z.x==x2 && z.y==y2)
{
cout<<z.time<<endl;
break;
}
qishi.pop();
for(int i=0;i<8;i++)
{
node z2;
z2.x=z.x+aid[i][0];
z2.y=z.y+aid[i][1];
z2.time=z.time+1;
if(z2.x>=0 && z2.x<=n-1 && z2.y>=0 && z2.y<=n-1 && vis[z2.x][z2.y]==0)
{
vis[z2.x][z2.y]=1;
qishi.push(z2);
}
}
}
while(!qishi.empty())
{
qishi.pop();
}
}
}