UVA 1595

The figure shown on the left is left-right symmetric as it is possible to fold the sheet of paper along a
vertical line, drawn as a dashed line, and to cut the figure into two identical halves. The figure on the
right is not left-right symmetric as it is impossible to find such a vertical line.
Write a program that determines whether a figure, drawn with dots, is left-right symmetric or not.
The dots are all distinct.
Input
The input consists of T test cases. The number of test cases T is given in the first line of the input file.
The first line of each test case contains an integer N, where N (1 ≤ N ≤ 1, 000) is the number of dots
in a figure. Each of the following N lines contains the x-coordinate and y-coordinate of a dot. Both
x-coordinates and y-coordinates are integers between −10, 000 and 10, 000, both inclusive.
Output
Print exactly one line for each test case. The line should contain ‘YES’ if the figure is left-right symmetric,
and ‘NO’, otherwise.
Sample Input
3
5
-2 5
0 0
6 5
4 0
2 3
4
2 3
0 4
4 0
0 0
4
5 14
6 10
5 10
6 14
Sample Output
YES
NO
YES

ac代码
#include<bits/stdc++.h>
typedef long long ll;
typedef double db;
const ll mod = 1e9+7;
const int N = 1e5+20;
#define dep(i,a,b) for(int i=(a);i>=(b);i–)
#define rep(i,a,b) for(int i=(a);i<=(b);i++)
#define mes§ memset(p,0,sizeof§)
using namespace std;
pair<int,int> point[1002];
set< pair<int,int> > a;//set用于判断点是否存在
int main()
{
int t,n;
cin>>t;
while(t–){
cin>>n;
int x,y,l=100000,r=-100000;
rep(i,1,n){
cin>>x>>y;
point[i]=make_pair(x,y);
a.insert(point[i]);
if(l>point[i].first) l=point[i].first;
if(r<point[i].first) r=point[i].first;
}
double mid=(double)(l+r)/2;
sort(point+1,point+1+n);
if((n&1)&&(point[(n+1)/2].first!=mid)) cout<<“NO”;
else{
int flag=1;
rep(i,1,n/2)
if(!a.count(pair<int,int>(l+r-point[i].first,point[i].second))) flag=0;
if(flag) cout<<“YES”;
else cout<<“NO”;
}
cout<<endl;
}
return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值