Text Reverse
Time Limit:1000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u
Practice
HDU 1062
Description
Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single line with several words. There will be at most 1000 characters in a line.
Output
For each test case, you should output the text which is processed.
Sample Input
3
olleh !dlrow
m'I morf .udh
I ekil .mca
Sample Output
hello world!
I'm from hdu.
I like acm.
Hint:Remember to use getchar() to read '\n' after the interger T, then you may use gets() to read a line and process it.
/*一道简单的水题,但是我第一次没做对,因为单词中间的空格是不确定的,这个算法挺不错的*/
#include<stdio.h>
#include<string.h>
#include<ctype.h>
int main()
{
int t;
scanf("%d",&t);
getchar();
while (t--)
{
char a[1010];
gets(a);
int i=0,j,lena=strlen(a);
while (i<lena)
{
while (isspace(a[i]))
{
printf("%c",a[i]);
i++;
}
while (!isspace(a[i])&&i<lena)
i++;
j=i-1;
while (!isspace(a[j])&&j>=0)
{
printf("%c",a[j]);
j--;
}
}
printf("\n");
}
return 0;
}