Wooden Sticks

Wooden Sticks
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
 
Description
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows: 


(a) The setup time for the first wooden stick is 1 minute. 
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup. 


You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2). 
 
Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces. 
 
Output
The output should contain the minimum setup time in minutes, one per line. 
 
Sample Input


4 9 5 2 2 1 3 5 1 4 

2 2 1 1 2 2 

1 3 2 2 3 1 
 
Sample Output
2
1



题目大意:有一堆木头要投入机器加工,如果后一个投入的木头长度l和重量w都大于它前一个投入的木头,那么这根木头的加工将不消耗时间,否则,需要花费一分钟加工这块木头

思路:还是贪心的思想,先将这几组木头按照长度或宽度从小到大的顺序排列(因为题目要求后面的木头大于前面的木头时不花费时间),我以长度排序举例,现有(4 9)(5 2)(2 1)(3 5)(1 4)5组木头,以长度排序,如果长度相等就按重量从小到大排序;排序后的顺序:(1 4)(2 1)(3 5)(4 9)(5 2),然后从i=0开始从前向后找出一组符合要求的,并标记它们,然后i++,跳过被标记的,继续找下一组,直到找完为止。

/*那啥,刚学STL,就想用vector来代替数组。vector不用考虑越界问题,这倒是比数组方便不少*/
#include<stdio.h>
#include<algorithm>
#include<vector>
using namespace std;
struct wood
{
    int l;
    int w;
};
bool cmp(struct wood a,struct wood b)
{
    if (a.l==b.l)
        return a.w<b.w;
    return a.l<b.l;
}
int main()
{
    int t;
    vector<struct wood> v(5005);
    scanf("%d",&t);
    while (t--)
    {
        int n,i,j,mark[5050]={0},s=0;
        scanf("%d",&n);
        for (i=0;i<n;i++)
        {
            scanf("%d %d",&v[i].l,&v[i].w);
        }
        sort(v.begin(),v.begin()+n,cmp);
        for (i=0;i<n;i++)
        {
            if (mark[i])
                continue;
            int q=v[i].w;
            for (j=i+1;j<n;j++)
            {
                if (q<=v[j].w&&!mark[j])
                {
                    q=v[j].w;
                    mark[j]=1;
                }
            }
            s++;
        }
        printf("%d\n",s);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值