【POJ 2572】Seek the Name, Seek the Fame

问题描述
The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm:

Step1. Connect the father’s name and the mother’s name, to a new string S.
Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S).

Example: Father=’ala’, Mother=’la’, we have S = ‘ala’+’la’ = ‘alala’. Potential prefix-suffix strings of S are {‘a’, ‘ala’, ‘alala’}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:)
输入
The input contains a number of test cases. Each test case occupies a single line that contains the string S described above.

Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000.
输出
For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby’s name.
样例输入
ababcababababcabab
aaaaa
样例输出
2 4 9 18
1 2 3 4 5
算法讨论
这道题略微涉及到了一点KMP算法,题目大意就是找出前缀和后缀相同的有几种可能,并记录长度,我们知道KMP算法中的P数组就是拿来记录这个的,所以把那部分拿来解题就好,具体的KMP算法等到以后在题目中用到在详细解释。

#include<cstdio>
#include<cstring>
using namespace std;
char st[400000];
int p[400000];
int a[400000];

void dfs(int n)
{
    if (p[n]!=-1)
    {
        dfs(p[n]);
        printf("%d%c",p[n]+1,' ');
    }
}

int main()
{
    while (gets(st)!=NULL)
    {
        int l;
        l=strlen(st);
        p[0]=-1;
        int j=-1;
        for (int i=1;i<l;i++)
        {
            while ((j>-1)&&(st[j+1]!=st[i]))
                j=p[j];
            if (st[j+1]==st[i])
                j=j+1;
            p[i]=j;
        }
        dfs(l-1);
        printf("%d\n",l);
    }
    return 0;
}

这里写图片描述
Pixiv ID:62368958

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值