poj 1328 Radar Installation

题目链接:点击打开链接

Radar Installation
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 101567 Accepted: 22607

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d. 

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates. 
 
Figure A Sample Input of Radar Installations


Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases. 

The input is terminated by a line containing pair of zeros 

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1

Source


#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <algorithm>
using namespace std;

struct part
{
    double x;
    double y;
};

struct part a[10000];
double d,max1;
int n,i,j,ans,num,v;
char ch;
double tx,dx,l,r;

bool cmp(struct part p, struct part q)
{
    if (p.x==q.x) return(p.y<q.y); else
    return(p.x<q.x);
}

int main()
{
    num=0;
    while (1)
    {
        scanf("%d%lf",&n,&d);
        if (n==0&&d==0) break;
        num+=1;
        v=0;
        for (i=0;i<=n-1;i++)
         {
             scanf("%lf%lf",&l,&r);
             if (r>d) v=1;
             a[i].x=(l-sqrt(d*d-r*r));
             a[i].y=(l+sqrt(d*d-r*r));
         }
         ch=getchar();
         if (v==1) {printf("Case %d: -1\n",num); continue;}
         sort(a,a+n,cmp);
         l=a[0].x; r=a[0].y;
         if (n!=0) ans=1; else ans=0;
         for (i=1;i<=n-1;i++)
         {
           if (r>=a[i].x)
             r=min(r,a[i].y); else
             {ans+=1; l=a[i].x; r=a[i].y;}
         }
         printf("Case %d: %d\n",num,ans);
    }
    return(0);
}

PS:第一次想错了,和这位博文作者想的一样。。没想出来bug

博文链接点击打开链接

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值