暴力水题(思路很重要)HDU5583

Kingdom of Black and White

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 243    Accepted Submission(s): 98


Problem Description
In the Kingdom of Black and White (KBW), there are two kinds of frogs: black frog and white frog.

Now  N  frogs are standing in a line, some of them are black, the others are white. The total strength of those frogs are calculated by dividing the line into minimum parts, each part should still be continuous, and can only contain one kind of frog. Then the strength is the sum of the squared length for each part.

However, an old, evil witch comes, and tells the frogs that she will change the color of  at most one frog and thus the strength of those frogs might change.

The frogs wonder the  maximum possible strength after the witch finishes her job.
 

Input
First line contains an integer  T , which indicates the number of test cases.

Every test case only contains a string with length  N , including only  0  (representing
a black frog) and  1  (representing a white frog).

  1T50 .

 for 60% data,  1N1000 .

 for 100% data,  1N105 .

 the string only contains 0 and 1.
 

Output
For every test case, you should output " Case #x: y",where  x  indicates the case number and counts from  1  and  y  is the answer.
 

Sample Input
  
  
2 000011 0101
 

Sample Output
  
  
Case #1: 26 Case #2: 10
 

Source

2015ACM/ICPC亚洲区上海站-重现赛(感谢华东理工)




#include<stdio.h>
#include<string.h>
long long max(long long a,long long b)
{
    if(a<b)
        return  b;
    else return a;
}
int  main()
{
    long long test;
    int sb=1;
    scanf("%I64d",&test);
    while(test--)
    {
        char a[100005];
        long long map[100005];

        memset(map,0,sizeof(map));
        scanf("%s",a);
        long long la=strlen(a);
        long long count=0;
        long long res=0;
        for(long long i=0; i<la;)
        {
            long long j=i;
            while(j<la&&a[i]==a[j])
                j++;
            map[count]=j-i;
            res+=map[count]*map[count];
            count++;
            i=j;
        }
//        prlong longf("count:%I64d\n",count);
//        for(long long  i=0; i<count; i++)
//            prlong longf("%I64d\n",map[i]);
        if(count==1)
        {
            printf("Case #%d: %I64d\n",sb++,res);
            continue;
        }
        long long ans=res;
        for(long long i=0; i<count; i++)//当长度为1是会对左右都产生影响,不为1则没有影响
        {

            long long  t=res;
            if(map[i]==1)
            {
                long long  now=map[i];
                t-=map[i]*map[i];
                if(i<count-1)
                {
                    now+=map[i+1];
                    t-=map[i+1]*map[i+1];
                }
                if(i)
                {
                    now+=map[i-1];
                    t-=map[i-1]*map[i-1];
                }
                t+=now*now;
                ans=max(ans,t);
            }
            else
            {

                if(i<count-1)
                {
                    long long temp=res;
                    temp-=map[i]*map[i];
                    temp-=(map[i+1])*(map[i+1]);
                    temp+=(map[i+1]+1)*(map[i+1]+1);
                    temp+=(map[i]-1)*(map[i]-1);
                    ans=max(ans,temp);
                }
                if(i)
                {
                    long long temp=res;
                    temp-=map[i]*map[i];
                    temp-=(map[i-1])*(map[i-1]);
                    temp+=(map[i-1]+1)*(map[i-1]+1);
                    temp+=(map[i]-1)*(map[i]-1);
                    ans=max(ans,temp);
                }

            }
        }
        printf("Case #%d: %I64d\n",sb++,ans);

    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值