数据结构08——逆波兰式

Time Limit: 3000ms, Memory Limit: 10000KB    , Accepted: 277, Total Submissions: 763

Description
假设表达式由单字母变量和双目四则运算算符构成。试编写程序,将一个通常书写形式且书写正确的表达式转换为逆波兰式。

Input
输入由单字母变量和双目四则运算算符构成的表达式。

Output
输出其逆波兰式。
样例输入:

(a+b)*c

样例输出:

ab+c*
#include <iostream>
#include <stack>
#include <string>
using namespace std;

bool judge(char x,char y){
    if(x=='*'&&(y=='+'||y=='-'))
        return true;
    else if(x=='/'&&(y=='+'||y=='-'))
        return true;
    else
        return false;
}

int main()
{
    string str;
    stack<char> s;

    cin>>str;
    int i;
    char t;
    int len=str.length();
    for(i=0;i<len;i++){
        if(str[i]>='a'&&str[i]<='z'){
            cout<<str[i];
        }
        else if(str[i]=='('){
            s.push(str[i]);
        }
        else if(str[i]==')'){
            t=s.top();
            while(t!='('){
                cout<<t;
                s.pop();
                t=s.top();
            }
            s.pop();
        }
        else{
            while(1){
                if(!s.empty())
                    t=s.top();
                else
                    t=-1;

                if(judge(str[i],t)||s.empty()||t=='('){
                    s.push(str[i]);
                    break;              //优先级大于栈顶元素,压栈
                }
                else if(t=='+'||t=='-'||t=='*'||t=='/'){
                    cout<<t;
                    s.pop();
                }
                else{
                    break;
                }
            }
        }

    }

    while(!s.empty()){
        char t=s.top();
        if(t!='(')  cout<<t;
        s.pop();
    }
    cout<<endl;
    return 0;
}

注意事项:

当栈为空时,s.top()函数会出错导致程序无法继续运行,需要特殊处理一下。

  • 1
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值