Piotr's Ants
the ants will soon be here. And I, for one, welcome our
new insect overlords."
Kent Brockman
Piotr likes playing with ants. He hasn of them on a horizontalpoleL cm long. Each ant is facing either left or right and walksat a constant speed of 1 cm/s. When two ants bump into each other, theyboth turn around (instantaneously) and start walking in opposite directions.Piotr knows where each of the ants starts and which direction it is facingand wants to calculate where the ants will end upT seconds from now.
Input
The first line of input gives the number of cases, N. Ntest cases follow. Each one starts with a line containing 3 integers:L ,T andn (0 <= n <= 10000).The nextn lines give the locations of then ants (measuredin cm from the left end of the pole) and the direction they are facing(L or R).
Output
For each test case, output one line containing "Case #x:"followed byn lines describing the locations and directions of then ants in the same format and order as in the input. If two or moreants are at the same location, print "Turning" instead of "L" or "R" fortheir direction. If an ant falls off the polebefore T seconds,print "Fell off" for that ant. Print an empty line after each test case.
sample input
2
10 1 4
1 R
5 R
3 L
10 R
10 2 3
4 R
5 L
8 R
sample output
Case #1:
2 Turning
6 R
2 Turning
Fell off
Case #2:
3 L
6 R
10 R
代码示例
#include<bits/stdc++.h>
using namespace std;
const int maxn=10010;
struct ant{
int num;
int pos;
int flag;
bool operator < (const ant & a) const{
return pos<a.pos;
}
}before[maxn],after[maxn];
const char dirname[][10]={"L","Turning","R"};
int order[maxn];
int main()
{
//freopen("read.txt","r",stdin);
//freopen("write.txt","w",stdout);
std::ios::sync_with_stdio(false);
int N,T;
cin>>N;
T=N;
int l,t,n;
while(N--)
{
cin>>l>>t>>n;
for(int i=0;i<n;++i){
int pos,flag;
char c;
cin>>pos>>c;
flag=(c=='L'?-1:1);
before[i]=(ant){i,pos,flag};
after[i]=(ant){0,pos+flag*t,flag};
}
sort(before,before+n);
for(int i=0;i<n;++i)
order[before[i].num]=i;//这一步很关键,因为num是唯一的,所以order数组是填满的
//其相当于一个映射 即给一个key表示num(输入序号),返回value其在轴上的位置(左数第几个)
sort(after,after+n);
for(int i=0;i<n-1;++i)
if(after[i].pos==after[i+1].pos) after[i].flag=after[i+1].flag=0;
cout<<"Case #"<<T-N<<':'<<endl;
for(int i=0;i<n;++i){
int a=order[i];
if(after[a].pos<0||after[a].pos>l) cout<<"Fell off"<<endl;
else cout<<after[a].pos<<' '<<dirname[after[a].flag+1]<<endl;
}
cout<<endl;
}
return 0;
}