problem
The inversion number of a given number sequence a1, a2, …, an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.
For a given sequence of numbers a1, a2, …, an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:
a1, a2, …, an-1, an (where m = 0 - the initial seqence)
a2, a3, …, an, a1 (where m = 1)
a3, a4, …, an, a1, a2 (where m = 2)
…
an, a1, a2, …, an-1 (where m = n-1)
You are asked to write a program to find the minimum inversion number out of the above sequences.
Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.
Output
For each case, output the minimum inversion number on a single line.
Sample Input
10
1 3 6 9 0 8 5 7 4 2
Sample Output
16
思路
题意:求一个数列不断Inversion后拥有最小逆序数的数列
借助线段树求出最初逆序数(O(nlogn)复杂度),就可以用O(1)的复杂度分别递推出其他解
核心代码(求一个序列的逆序数)(这里不用考虑离散化):
for(int i=1;i<=n;++i){
scanf("%d",&arr[i]);
sum+=query(arr[i]+1,n,1,n,1);//注意为什么这样可以求出逆序对数
update(arr[i],1,n,1);
}
//理解:对于一个序列,从左往右每次查询一个区间里的数字个数,哪个区间呢?arr[i]~n-1这个区间,因为是从左往右的,那么当这个区间里有数时,说明比arr[i]大的数字在它之前出现了,即逆序数。
//然后update,改变arr[i],使其num++。这样当后面出现比它小的数字,这个数字又做了上面的query,发现之前arr[i]比它大,数量即为num。
//手跑代码有助于理解
代码示例
#include<bits/stdc++.h>
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
using namespace std;
const int maxn=5050;
int arr[maxn];
int sum[maxn<<2];
void PushUp(int rt){
sum[rt]=sum[rt<<1]+sum[rt<<1|1];
}
void build(int l,int r,int rt){
sum[rt]=0;
if(l==r) return ;
int m=(l+r)>>1;
build(lson);
build(rson);
}
void update(int p,int l,int r,int rt){
if(l==r){
sum[rt]++;
return ;
}
int m=(l+r)>>1;
if(p<=m) update(p,lson);
else update(p,rson);
PushUp(rt);
}
int query(int L,int R,int l,int r,int rt){
if(L<=l&&r<=R){
return sum[rt];
}
int m=(l+r)>>1;
int ret=0;
if(L<=m) ret+=query(L,R,lson);
if(R>m) ret+=query(L,R,rson);
return ret;
}
int main()
{
int n;
while(~scanf("%d",&n)){
build(1,n,1);
int sum=0;
for(int i=1;i<=n;++i){
scanf("%d",&arr[i]);
sum+=query(arr[i]+1,n,1,n,1);//注意为什么这样可以求出逆序对数
update(arr[i],1,n,1);
}
int ret=sum;
int flag=0;
//cout<<sum<<" "<<++flag<<endl;
for(int i=1;i<n;++i){
sum+=n-1-2*arr[i];//注意这里计算的含义
//cout<<sum<<" "<<++flag<<endl;
ret=min(ret,sum);
}
printf("%d\n",ret);
}
return 0;
}