POJ 2528(线段树,区间覆盖,离散化思想)

problem

The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral posters at all places at their whim. The city council has finally decided to build an electoral wall for placing the posters and introduce the following rules:
Every candidate can place exactly one poster on the wall.
All posters are of the same height equal to the height of the wall; the width of a poster can be any integer number of bytes (byte is the unit of length in Bytetown).
The wall is divided into segments and the width of each segment is one byte.
Each poster must completely cover a contiguous number of wall segments.

They have built a wall 10000000 bytes long (such that there is enough place for all candidates). When the electoral campaign was restarted, the candidates were placing their posters on the wall and their posters differed widely in width. Moreover, the candidates started placing their posters on wall segments already occupied by other posters. Everyone in Bytetown was curious whose posters will be visible (entirely or in part) on the last day before elections.
Your task is to find the number of visible posters when all the posters are placed given the information about posters’ size, their place and order of placement on the electoral wall.

Input

The first line of input contains a number c giving the number of cases that follow. The first line of data for a single case contains number 1 <= n <= 10000. The subsequent n lines describe the posters in the order in which they were placed. The i-th line among the n lines contains two integer numbers l i and ri which are the number of the wall segment occupied by the left end and the right end of the i-th poster, respectively. We know that for each 1 <= i <= n, 1 <= l i <= ri <= 10000000. After the i-th poster is placed, it entirely covers all wall segments numbered l i, l i+1 ,… , ri.

Output

For each input data set print the number of visible posters after all the posters are placed.

The picture below illustrates the case of the sample input.

Sample Input

1
5
1 4
2 6
8 10
3 4
7 10
Sample Output
4


思路

这题给的数据可以到1e7,所以直接在线段树上赋值会存不下,即使存下了时间复杂度不符。
所以这里用一种(逆)离散化的思想,因为最多10000个海报,让这些海报的点排序再从新对应更小的数(这里直接是数组下标就可以),对应后相对顺序不变(精髓)
另外值得注意的是,本题是求是否露出海报,在(逆)离散化后,之前有空隙能露出的海报现在因为更紧密而漏不出来了。因此要在仅差距1个单位的端点之间插入数。核心代码:

for(int i=mm-1;i>0;--i){
            if(arr[i]!=arr[i-1]+1) arr[mm++]=arr[i-1]+1;
        }

另外,要注意数组空间大小。涉及两个端点,间隙加数,线段树(2*2*4=16)本菜因为此而RE了


代码示例

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
using namespace std;

const int maxn=10100;
bool hash[maxn];//方便查找是否能看见海报;
int li[maxn],ri[maxn];//所给数据
int arr[maxn<<2];//整合数据进行离散化
int cov[maxn<<4];//线段树结点信息
int ans;

void PushDown(int rt){
    if(cov[rt]){
        cov[rt<<1]=cov[rt<<1|1]=cov[rt];
        cov[rt]=0;
    }
}

void update(int L,int R,int c,int l,int r,int rt){
    if(L<=l&&r<=R){
        cov[rt]=c;
        return ;
    }
    PushDown(rt);
    int m=(l+r)>>1;
    if(L<=m) update(L,R,c,lson);
    if(m<R) update(L,R,c,rson);
}

void query(int l,int r,int rt){
    if(cov[rt]){
        if(!hash[cov[rt]]) ans++;
        hash[cov[rt]]=true;
        return ;
    }
    if(l==r) return ;
    int m=(l+r)>>1;
    query(lson);
    query(rson);
}

int main()
{
    int T,n;
    scanf("%d",&T);
    while(T--)
    {
        memset(cov,0,sizeof(cov));
        memset(hash,false,sizeof(hash));
        ans=0;
        scanf("%d",&n);
        int cnt=0;
        for(int i=0;i<n;++i){
            scanf("%d %d",&li[i],&ri[i]);
            arr[cnt++]=li[i];
            arr[cnt++]=ri[i];
        }
        sort(arr,arr+cnt);
        int mm=1;
        for(int i=1;i<cnt;++i){
            if(arr[i]!=arr[i-1]){
                arr[mm++]=arr[i];
            }
        }//注意这里我一开始arr数组开小了
        //它的数据是到1e7的,所以存在都不相同的情况,已经2*maxn了
        //然后下面差距又都大于1 所以又会2*maxn
        //所以开4倍比较保险
        for(int i=mm-1;i>0;--i){
            if(arr[i]!=arr[i-1]+1) arr[mm++]=arr[i-1]+1;
        }
        sort(arr,arr+mm);
        for(int i=0;i<n;++i){
            int l=lower_bound(arr,arr+mm,li[i])-arr+1;
            int r=lower_bound(arr,arr+mm,ri[i])-arr+1;
            update(l,r,i+1,1,mm,1);//l r在1~4*maxn 之间 所以 线段树要开maxn的16倍才比较稳
        }
        query(1,mm,1);
        printf("%d\n",ans);
    }
    return 0;
}
评论 4
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值