PAT A1077 Kuchiguse (20分)

题目:

The Japanese language is notorious for its sentence ending particles. Personal preference of such particles can be considered as a reflection of the speaker's personality. Such a preference is called "Kuchiguse" and is often exaggerated artistically in Anime and Manga. For example, the artificial sentence ending particle "nyan~" is often used as a stereotype for characters with a cat-like personality:

  • Itai nyan~ (It hurts, nyan~)

  • Ninjin wa iyada nyan~ (I hate carrots, nyan~)

Now given a few lines spoken by the same character, can you find her Kuchiguse?

Input Specification:

Each input file contains one test case. For each case, the first line is an integer N (2≤N≤100). Following are Nfile lines of 0~256 (inclusive) characters in length, each representing a character's spoken line. The spoken lines are case sensitive.

Output Specification:

For each test case, print in one line the kuchiguse of the character, i.e., the longest common suffix of all N lines. If there is no such suffix, write nai.

Sample Input 1:

3
Itai nyan~
Ninjin wa iyadanyan~
uhhh nyan~

Sample Output 1:

nyan~

Sample Input 2:

3
Itai!
Ninjinnwaiyada T_T
T_T

Sample Output 2:

nai

难度:两颗星(满五颗星)

思路:1、题目本质是找到一组字符串结尾相同的字符并输出。

           2、string input[110] 储存输入的字符串,将每一个字符串反转,挨个字符比较,直至字符不同或者有一个字符串没有字符                   为止,并将所有输入字符串中都有的字符存到out中,out即为所要求得的结果。

代码:

#include<iostream>
#include<string>
#include<algorithm>
using namespace std;
string input[110];
int main()
{
    int n;
    cin >> n;
    cin.get();
    int min_length = 260;
    for(int i=0; i<n; i++)
    {
        getline(cin, input[i]);
        reverse(input[i].begin(), input[i].end());
        if(input[i].size() < min_length)
            min_length = input[i].size();
    }
    string out;
    int j=0;
    while(1)
    {
        int flag=1;
        int i=1;
        for(; i<n; i++)
        {
            if(j>=min_length || input[i][j]!=input[i-1][j])
            {
                flag = 0;
                break;
            }
        }
        if(flag==0)
            break;
        out += input[0][j];     //Out += input[i][j]是错误的
        j++;
    }
    reverse(out.begin(), out.end());
    if(out.size()==0)
        cout << "nai";
    else
        cout << out;
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值