find your present (2)

     In the new year party, everybody will get a "special present".Now it's your turn to get your special present, a lot of presents now putting on the desk, and only one of them will be yours.Each present has a card number on it, and your present's card number will be the one that different from all the others, and you can assume that only one number appear odd times.For example, there are 5 present, and their card numbers are 1, 2, 3, 2, 1.so your present will be the one with the card number of 3, because 3 is the number that different from all the others. 
Input
    The input file will consist of several cases.
    Each case will be presented by an integer n (1<=n<1000000, and n is odd) at first. Following that, n positive integers will be given in a line, all integers will smaller than 2^31. These numbers indicate the card numbers of the presents.n = 0 ends the input.
Output
    For each case, output an integer in a line, which is the card number of your present.
Sample Input

    5
    1 1 3 2 2
    3
    1 2 1
    0

Sample Output

    3
    2


            
      
    use scanf to avoid Time Limit Exceeded

Hint

    Hint
            
     


这道题拿到手的思想就是开一个数组num【】先全赋值为0,每次输入一个数x,就把这个数x对应的数组num【x】++,最后取出次数为1的数据即可。

报错RTIME

#include<stdio.h>
#include<iostream>
using namespace std;
int main(){
	int n,x;
	while(scanf("%d",&n),n){
		int num[100001]={0};
		while(n--){
			scanf("%d",&x);
			num[x]++;
		}
		for(int i=0;i<100001;i++){
			if(num[i]==1)
			printf("%d\n",i);
		}
	}
}

再次,提及一个知识点:位异或运算符^

异或运算符的特点是:数a两次异或同一个数b(a=a^b^b)仍然为原值a.详细解析:http://blog.csdn.net/u014427196/article/details/40650683 感谢博主。

#include <stdio.h>
int main()
{
    int n,x,ans;
    while(scanf("%d",&n),n)
    {
        ans = 0;
        while(n--)
        {
            scanf("%d",&x);
            ans ^= x;
        }
        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值