[USACO08DEC]干草出售Hay For Sale——动态规划

[USACO08DEC]干草出售Hay For Sale——动态规划



题目来源

洛谷P2925


题目描述

Farmer John suffered a terrible loss when giant Australian cockroaches ate the entirety of his hay inventory, leaving him with nothing to feed the cows. He hitched up his wagon with capacity C (1 <= C <= 50,000) cubic units and sauntered over to Farmer Don’s to get some hay before the cows miss a meal.

Farmer Don had a wide variety of H (1 <= H <= 5,000) hay bales for sale, each with its own volume (1 <= V_i <= C). Bales of hay, you know, are somewhat flexible and can be jammed into the oddest of spaces in a wagon.

FJ carefully evaluates the volumes so that he can figure out the largest amount of hay he can purchase for his cows.

Given the volume constraint and a list of bales to buy, what is the greatest volume of hay FJ can purchase? He can’t purchase partial bales, of course. Each input line (after the first) lists a single bale FJ can buy.

约翰遭受了重大的损失:蟑螂吃掉了他所有的干草,留下一群饥饿的牛.他乘着容量为C(1≤C≤50000)个单位的马车,去顿因家买一些干草. 顿因有H(1≤H≤5000)包干草,每一包都有它的体积Vi(l≤Vi≤C).约翰只能整包购买,

他最多可以运回多少体积的干草呢?

输入格式:
Line 1: Two space-separated integers: C and H

Lines 2..H+1: Each line describes the volume of a single bale: V_i

输出格式:
Line 1: A single integer which is the greatest volume of hay FJ can purchase given the list of bales for sale and constraints.

输入样例#1:
7 3
2
6
5
输出样例#1:
7
说明

The wagon holds 7 volumetric units; three bales are offered for sale with volumes of 2, 6, and 5 units, respectively.

Buying the two smaller bales fills the wagon.


解题思路

本题很明显可以用01背包解决,但是如果直接套用01背包的格式,会在最后一个测试点超时,因此我添加了部分优化:

  • 用滚动数组f[i]表示当车辆容量为i时能装干草的最大体积
  • 由于需要从小到大遍历车的容量,假设当前车的容量是a,那么f[a]一定小于等于a。(证明 : 车辆最多能装体积与车辆容量相等的干草)这说明当f[a]取a时就不用再一次对f[a]进行更新了,因为此时的f[a]已经取到最大值了
  • 由于车的总容量为c,那么这辆车最多只能装体积为c的干草。因此如果已经可以装到体积为c的干草就直接输出结果并退出

源代码

#include<iostream>
using namespace std;
int c,h;//c容量 h种情况 
int f[50005];
int v[50005];
int main(){
    cin >> c >> h;
    for(int i = 1;i <= h;i++)
        cin >> v[i];
    for(int i = 1;i <= h;i++){
        for(int a = c;a >= v[i];a--){
            if(f[a] == a)
                continue;  //此时f[a]已经取到最大值 就不用再对f[a]进行更新 
            if(f[a - v[i]] + v[i] > f[a])
                f[a] = f[a - v[i]] + v[i];
        }
        if(f[c] == c){//判断是否已经能够装满c体积的干草
            cout << c;//能够装满
            return 0;//退出
        }
    }
    cout << f[c];
    return 0;
}
  • 2
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值