VPN技术(GRE和MGRE)实验

一、实验拓扑图

二、实验要求

1、R5为ISP,只能进行IP地址配置,其所有地址均配为公有IP地址;
2、R1和R5间使用PPP的PAP认证,R5为主认证方;
   R2与R5之间使用ppp的CHAP认证,R5为主认证方;
   R3与R5之间使用HDLC封装;
3、R1、R2、R3构建一个MGRE环境,R1为中心站点,R1、R4间为点到点的GRE;
4、整个私有网络基本RIP全网可达;
5、所有Pc设置私有IP为源IP,可以访问R5环回。

三、实验步骤

1、R5为ISP,只能进行IP地址配置,其所有地址均配为公有IP地址;

先给每个接口配置IP地址

R1:

[R1]int g0/0/0
[R1-GigabitEthernet0/0/0]ip address 192.168.1.254 24

[R1]int Serial 4/0/0
[R1-Serial4/0/0]ip address 15.1.1.1 24
[R1]dis ip interface brief 

R2:

[R2]int g0/0/0
[R2-GigabitEthernet0/0/0]ip address 192.168.2.254 24

[R2]int s4/0/0
[R2-Serial4/0/0]ip address 25.1.1.2 24
[R2]dis ip interface brief 

R3:

[R3]int g0/0/0
[R3-GigabitEthernet0/0/0]ip address 192.168.3.254 24
[R3-GigabitEthernet0/0/0]q
[R3]int s4/0/0
[R3-Serial4/0/0]ip address 35.1.1.3 24
[R3]dis ip interface brief 

R4:

[R4]int g0/0/1
[R4-GigabitEthernet0/0/1]ip address 192.168.4.254 24
[R4-GigabitEthernet0/0/1]q

[R4]int g0/0/0
[R4-GigabitEthernet0/0/0]ip address 45.1.1.4 24
[R4]dis ip interface brief 

R5:

[R5]int s4/0/1
[R5-Serial4/0/1]ip add 15.1.1.5 24
[R5]int s3/0/1
[R5-Serial3/0/1]ip add 25.1.1.5 24
[R5]int s4/0/0
[R5-Serial4/0/0]ip add 35.1.1.5 24
[R5]int g0/0/0
[R5-GigabitEthernet0/0/0]ip add 45.1.1.5 24
[R5]int l0
[R5-LoopBack0]ip add 5.5.5.5 24

2、R1和R5间使用PPP的PAP认证,R5为主认证方;

R5证方:配置用户列表及验证方式

[R5]aaa
[R5-aaa]local-user ck password cipher 123 privilege level 15
[R5-aaa]local-user ck service-type ppp
[R5-aaa]int s4/0/1
[R5-Serial4/0/1]ppp authentication-mode pap

R1:被验证方

[R1]int s4/0/0
[R1-Serial4/0/0]ppp pap local-user ck password cipher 123

对R1和R5连接的端口都shutdown再开启:

R2与R5之间使用ppp的CHAP认证,R5为主认证方;

R5:主认证方:

[R5]aaa
[R5-aaa]local-user cc password cipher 456 privilege level 15
[R5-aaa]local-user cc service-type ppp
[R5-Serial3/0/1]ppp authentication-mode chap


R2:

[R2]int s4/0/0
[R2-Serial4/0/0]ppp chap user cc
[R2-Serial4/0/0]ppp chap password cipher 456

R3与R5之间使用HDLC封装;

两边接口下修改链路类型:

[R3]int s4/0/0
[R3-Serial4/0/0]link-protocol hdlc

[R5]int s4/0/0
[R5-Serial4/0/0]link-protocol hdlc

3、R1、R2、R3构建一个MGRE环境,R1为中心站点,R1、R4间为点到点的GRE;

我们先做R1、R4间为点到点的GRE;

1.先创建Tunnel接口并且将隧道IP地址加入其中,开启GRE类型

以及目标端口IP

R1:

[R1]int Tunnel 0/0/0    #创建隧道端口
[R1-Tunnel0/0/0]ip address 10.1.1.1 24        #建立隧道接口IP地址
[R1-Tunnel0/0/0]tunnel-protocol gre           #选择隧道类型
[R1-Tunnel0/0/0]source 15.1.1.1
[R1-Tunnel0/0/0]destination 45.1.1.4

R4:

[R4]int Tunnel 0/0/0
[R4-Tunnel0/0/0]ip address 10.1.1.2 24
[R4-Tunnel0/0/0]tunnel-protocol gre 	
[R4-Tunnel0/0/0]source 45.1.1.4	
[R4-Tunnel0/0/0]destination 15.1.1.1

在这里我们需要去配置在R1和R4的出口陪缺省路由才能ping通:

后续都需要使用缺省路由我们将其他几个路由器的缺省路由也配上吧

[R1]ip route-static 0.0.0.0 0 15.1.1.5
[R2]ip route-static 0.0.0.0 0 25.1.1.5
[R3]ip route-static 0.0.0.0 0 35.1.1.5
[R4]ip route-static 0.0.0.0 0 45.1.1.5

用R1----ping-----R4

接下来我们做R1、R2、R3构建一个MGRE环境,R1为中心站点

1.在做MGRE时首先还是先建立Tunnel隧道
2.给隧道添加IP地址
3.选择MGRE的类型
4.中心接口源IP时固定的写上去就好,但是分支站点不固定需要写他的接口
5.中心接口要开启伪广播,因为分支站点要向中心站点注册
6.设置NHRP的工作IP--下一跳解析协议

中心站点R1:

[R1]int Tunnel 0/0/1
[R1-Tunnel0/0/1]ip address 10.1.2.1 24        #隧道接口IP
[R1-Tunnel0/0/1]tunnel-protocol gre p2mp      #选择mgre环境
[R1-Tunnel0/0/1]source 15.1.1.1              #该隧道加封源IP,地址通过NHRP协议来获取加封的目标IP
[R1-Tunnel0/0/1]nhrp entry multicast dynamic   #本地成为NHRP服务端,开启伪广播,为RIP做准备
[R1-Tunnel0/0/1]nhrp network-id 100   #NHRP的工作编号

分支站点R2:

[R2]int Tunnel 0/0/1
[R2-Tunnel0/0/1]ip add 10.1.2.2 24
[R2-Tunnel0/0/1]tunnel-protocol gre p2mp 
[R2-Tunnel0/0/1]source s4/0/0
[R2-Tunnel0/0/1]nhrp entry 10.1.2.1 15.1.1.1 register 
[R2-Tunnel0/0/1]nhrp network-id 100

分支站点R3:

[R3]int Tunnel 0/0/1
[R3-Tunnel0/0/1]ip add 10.1.2.3 24
[R3-Tunnel0/0/1]tunnel-protocol gre p2mp 
[R3-Tunnel0/0/1]source s4/0/0
[R3-Tunnel0/0/1]nhrp network-id 100
[R3-Tunnel0/0/1]nhrp entry 10.1.2.1 15.1.1.1 register 

测试:在R1上查看R2和R3的都学到了,或者我们在上面对他们缺省路由都配置了可以使用R1对R2和R3使用ping -a

4、整个私有网络基本RIP全网可达;

在这里我们只需要宣告私网,因为公网地址私网学不到

R1:

[R1]rip 1
[R1-rip-1]v 2
[R1-rip-1]undo summary 
[R1-rip-1]network 192.168.1.0
[R1-rip-1]network 10.0.0.0

R2:

[R2]rip 1
[R2-rip-1]v 2
[R2-rip-1]undo summary 
[R2-rip-1]network 192.168.2.0
[R2-rip-1]network 10.0.0.0

R3:

[R3]rip 1
[R3-rip-1]v 2
[R3-rip-1]undo summary 
[R3-rip-1]network 192.168.3.0
[R3-rip-1]network 10.0.0.0

R4:

[R4]rip 1
[R4-rip-1]v 2
[R4-rip-1]undo summary 	
[R4-rip-1]network 192.168.4.0
[R4-rip-1]network 10.0.0.0
配置完后R2和R3路由条目不全,因为RIP的水平分割(从一个接口收到路由,不从这个接口传出去),所以需要关闭中心接口的水平分割

R1:

[R1]int Tunnel 0/0/1
[R1-Tunnel0/0/1]undo rip split-horizon    #关闭水平分割机制


5、所有PC设置私有IP为源IP,可以访问R5环回。

私有IP访问公网环回使用NAT配置:

R1:

[R1]acl 2000	
[R1-acl-basic-2000]rule permit source 192.168.1.0 0.0.0.255
[R1]int s4/0/0
[R1-Serial4/0/0]nat outbound 2000

R2:

[R2]acl 2000
[R2-acl-basic-2000]rule permit source 192.168.2.0 0.0.0.255
[R2]int s4/0/0
[R2-Serial4/0/0]nat outbound 2000

R3:

[R3]acl 2000
[R3-acl-basic-2000]rule permit source 192.168.3.0 0.0.0.255
[R3-acl-basic-2000]q
[R3]int s4/0/0	
[R3-Serial4/0/0]nat outbound 2000

R4:

[R4]acl 2000
[R4-acl-basic-2000]rule permit source 192.168.4.0 0.0.0.255
[R4-acl-basic-2000]q
[R4]int g0/0/0
[R4-GigabitEthernet0/0/0]nat outbound 2000

让PC1-------ping-----R5的环回

让PC2-------ping-----R5的环回

ping通了说明公私网nat转换成功了。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值