E - Rabbits HDU - 6227 (思维题)

Here N (N ≥ 3) rabbits are playing by the river. They are playing on a number line, each occupying a different integer. In a single move, one of the outer(注意!外面的兔子才可以跳) rabbits jumps into a space between any other two. At no point may two rabbits occupy the same position.
Help them play as long as possible
Input
The input has several test cases. The first line of input contains an integer t (1 ≤ t ≤ 500) indicating the number of test cases.
For each case the first line contains the integer N (3 ≤ N ≤ 500) described as above. The second line contains n integers a1a1 < a2a2 < a3a3 < … < aNaN which are the initial positions of the rabbits. For each rabbit, its initial position
aiai satisfies 1 ≤ aiai ≤ 10000.
Output
For each case, output the largest number of moves the rabbits can make.
Sample Input
5
3
3 4 6
3
2 3 5
3
3 5 9
4
1 2 3 4
4
1 2 4 5
Sample Output
1
1
3
0
1

思路:

找出每两只兔子之间的空格数,加在一起即可。
注意头部或者尾部的空格只能选择其中一个空大的跳(题目并没有说从那边开始跳,所以头尾其实处于同等地位),因为:选择一个方向为起始方向的话,头部那边的空就不能跳,因为外部没有兔子了。

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
int a[505];
int main()
{
    int t;
    while(scanf("%d", &t) != EOF){
        while(t--){
            int n;
            scanf("%d", &n);
            for(int i = 0; i < n; i++){
                scanf("%d", &a[i]);
            }
            int num = 0;
            for(int i = 2; i < n - 1; i++){
                num = num + a[i] - a[i - 1] - 1;
            }
            num += max((a[1]- a[0]),(a[n - 1] - a[n - 2])) - 1;
            printf("%d\n", num);
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值