1/21集训二 模拟+贪心 A.(贪心)Radar Installation 【在x轴上放置雷达】

1/21集训二 模拟+贪心

A.(贪心)Radar Installation 【在x轴上放置雷达】

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.
We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.
Figure A Sample Input of Radar Installations
这里写图片描述

Input
The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros
Output
For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. “-1” installation means no solution for that case.
Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output
Case 1: 2
Case 2: 1

题意:
给出小岛数量和雷达半径,要使得所有小岛被雷达覆盖,求放置的雷达的最小数量

思路:
雷达位置未知但是小岛位置固定,所以以小岛为中心考虑,可以找到x轴上对应的一个区间,在这个区间内的任何一个点放置雷达,都可以覆盖该小岛。那么问题即转化为已知一些区间,使得每个区间内至少存在一个点,问最少有多少点。
使用贪心算法,为了使每个雷达的覆盖的岛最多,从第一个区间开始,每次将雷达放置在区间的最右边右端点,再对下一个没有的区间进行操作,直到所有区间都包含一个点。

#include <stdio.h>
#include <math.h>
#include <stdbool.h>
#include <algorithm>
#include <iostream>
#define MAXN 1005
#define INF 0x3f3f3f3f3f3f3f3f
using namespace std;

struct Local
{
    double s, e;
};

bool cmp(Local a, Local b)
{
    return a.e < b.e;
}

int main()
{
    int n, d, kase = 1;
    while(scanf("%d%d", &n, &d) != EOF)
    {
        if(n == 0 && d == 0)
            break;
        struct Local loc[MAXN];
        int x, y, flag = 0;
        for(int i = 0; i < n; i++)
        {
            cin>>x>>y;
            if(y > d)
                flag = 1;
            else
            {
                double k = d * d - y * y;
                loc[i].s = x - sqrt(k);
                loc[i].e = x + sqrt(k);
            }
        }
        cout<<"Case "<<kase++<<": ";
        if(flag == 1)
            cout<<"-1"<<endl;
        else
        {
            sort(loc, loc + n, cmp);
            int ans = 0;
            double cur = -INF;
            for(int i = 0; i < n; i++)
            {
                if(cur < loc[i].s)
                {
                    ans++;
                    cur = loc[i].e;
                }
            }
            cout<<ans<<endl;
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值