【dfs】(经典样题) Prime Ring Problem HDU - 1016 【素数环】

【dfs】(经典样题)Prime Ring Problem HDU - 1016 【素数环】

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, …, n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.
这里写图片描述

Input
n (0 < n < 20).

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.

Sample Input
6
8

Sample Output
Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

思路:
注意检验最后一个数和第一个数相加是否为素数。

AC代码:

#include <iostream>
#include <stdio.h>
#include <math.h>
#include <algorithm>
#include <cstring>
#include <string>

using namespace std;

const int maxn = 25;
int isp[maxn * maxn], vis[maxn], ans[maxn];
int n;

void pri()
{
    memset(isp, 0, sizeof(isp));
    isp[1] = 1;
    for(int i = 2; i <= 100; i++)
    {
        int j;
        for(j = 2; j <= sqrt(i); j++)
        {
            if(i % j == 0)
                break;
        }
        if(j > sqrt(i))
            isp[i] = 1;
    }
}

void play(int cnt)
{
    if(cnt == n && isp[ans[0] + ans[n - 1]])
    {
        for(int i = 0; i < n - 1; i++)
            printf("%d ", ans[i]);
        printf("%d\n", ans[n - 1]);
        return ;
    }
    for(int i = 2; i <= n; i++)
    {
        if(!vis[i] && isp[i + ans[cnt - 1]])
        {
            ans[cnt] = i;
            vis[i] = 1;
            play(cnt + 1);
            vis[i] = 0;
        }
    }
}

int main()
{
    pri();
    int kase = 0;
    while(~scanf("%d", &n))
    {
        memset(vis, 0, sizeof(vis));
        ans[0] = 1;
        printf("Case %d:\n", ++kase);
        play(1);
        printf("\n");
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值