POJ 1001 Exponentitaion

Exponentiation
Time Limit: 500MS Memory Limit: 10000K
Total Submissions: 126831 Accepted: 30948

Description

Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems. 

This problem requires that you write a program to compute the exact value of R n where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25.

Input

The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9.

Output

The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don't print the decimal point if the result is an integer.

Sample Input

95.123 12
0.4321 20
5.1234 15
6.7592  9
98.999 10
1.0100 12

Sample Output

548815620517731830194541.899025343415715973535967221869852721
.00000005148554641076956121994511276767154838481760200726351203835429763013462401
43992025569.928573701266488041146654993318703707511666295476720493953024
29448126.764121021618164430206909037173276672
90429072743629540498.107596019456651774561044010001
1.126825030131969720661201

解该题的主要思路是:

因为结果是一个很大的数,所以可以考虑用数组来存储。因为我们不知道这个结果到底有多少们一,所以我们可以将基数取反相乘。然后一步一步向前进位。work数组的下标0,表示的是结果的最低位。

       注意,输出进,整数没有小数点。前导0也不用输出 ,小数点后多余的0也不用输出 。

代码:

#include<stdio.h>
#include<stdlib.h>
#include<string.h>

#define DIGIT 128

int nR[5];
int work[DIGIT];
int baseSize=0,size=0;

int reverseR(char *str){
    int point=0;	//用于除去0后,输入的数有保留几位有效数字。如12.100,除去后面的两个零,就只有1位小数啦。 
    char *tmp=(char*)malloc(sizeof(char)*strlen(str));
    int k=0,i=strlen(str);
    while(--i>=0){
	tmp[k++]=str[i];
    }
    tmp[k]='\0';
   //用于删除小数点后面,保留的数的0的总数,如12.100 后面有2个0,是不用参加运算的。
    while(*tmp!='\0'&& *tmp=='0'){
	tmp++;
    }
    k=0;
    while(*tmp!='\0'){
         str[k++]=*tmp++;
    }
    str[k]='\0';
    tmp=str;
    while(*tmp!='\0'&& *tmp!='.'){
	tmp++;point++;}
	tmp++;i=point;
    while(*tmp!='\0'){
	str[i++]=*tmp++;
    }
    str[i]='\0';
   return point;
}

void exponent(int n){
     int i,j,k,t;
     int nTemp[DIGIT]={0};
     int temp=0,tempSize;
     if(--n<1)
	 return;
     for(j=0;j<=baseSize;j++){
        for(k=0;k<=size;k++){
		temp+=nTemp[j+k]+nR[j]*work[k];
         	nTemp[j+k]=temp%10;			//temp是用来保存当前坚式的总和,但是若是有进位的话就进行向前进位。
		temp/=10;
	     }
         while(temp){					//处理最后一个坚式和的进位问题。
     	     nTemp[j+k++]=temp%10;
	     temp/=10;
          }
	  tempSize=j+k-1;
     }
     size=tempSize;
     memcpy(work,nTemp,sizeof(int)*DIGIT);
     exponent(n);
}

int main(void){
    char R[7];
    int n,i;
    int point=0;

    while(scanf("%s%d",R,&n)==2){
	 if(n==0){
	     printf("1\n");
	     continue;
	  }
	 point=reverseR(R);
         size=baseSize=strlen(R)-1;
	 for(i=0;i<strlen(R);i++)
	    work[i]= nR[i]=R[i]-'0';
	if(n>=1)
	   exponent(n);
	//输出控制
	if(size==point*n){
	    if(work[size]==0)
		 printf(".");
            else
		printf("%d.",work[size]);
	     i=size-1;
	     for(;i>=0;i--)
               printf("%d",work[i]);
	}else{
	    i=size;
	    int k=size-n*point;
	    while(k-->=0)
		printf("%d",work[i--]);
	    if(i>=0)
	    	printf(".");
	    for(;i>=0;i--)
		printf("%d",work[i]);
	}
        printf("\n");	
	memset(work,0,sizeof(work));
	memset(nR,0,sizeof(nR));
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值