1127. ZigZagging on a Tree (30)

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences. And it is a simple standard routine to print the numbers in level-order. However, if you think the problem is too simple, then you are too naive. This time you are supposed to print the numbers in "zigzagging order" -- that is, starting from the root, print the numbers level-by-level, alternating between left to right and right to left. For example, for the following tree you must output: 1 11 5 8 17 12 20 15.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<= 30), the total number of nodes in the binary tree. The second line gives the inorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the zigzagging sequence of the tree in a line. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
8
12 11 20 17 1 15 8 5
12 20 17 11 15 8 5 1
Sample Output:

1 11 5 8 17 12 20 15


#include<cstdio>
#include<queue>
#include<vector>
#include<algorithm>
using namespace std;


int vert;//节点数
vector<int> in,post,level[32];
struct Node{
int val,lel;
Node *lchild,*rchild;
Node():lchild(NULL),rchild(NULL){}


};//struct类型后面记得加分号


int maxlel = -1;
Node* create(int inl,int inr,int pl,int pr,int lel){//创建树的同时将每层的结点加入到容器中
if(inl>inr || pl>pr)
return NULL;


Node *root = new Node();//申请新结点
root->val = post[pr];
root->lel = lel;
maxlel = max(lel,maxlel);
level[lel].push_back(root->val);
int k;
for(k = inl;k<=inr;k++)
if(in[k] == post[pr])
break;
int rlen = inr-k;
root->lchild = create(inl,k-1,pl,pr-rlen-1,lel+1);
root->rchild = create(k+1,inr,pr-rlen,pr-1,lel+1);
return root;
}


int main(void){
scanf("%d",&vert);
in.resize(vert);
post.resize(vert);
for(int i = 0;i<vert;i++)
scanf("%d",&in[i]);
for(int i = 0;i<vert;i++)
scanf("%d",&post[i]);
Node *root = NULL;
root = create(0,vert-1,0,vert-1,0);
printf("%d",level[0][0]);
for(int i = 1;i<=maxlel;i++){
if(i%2==0)
for(int j = level[i].size()-1;j>=0;j--)
printf(" %d",level[i][j]);
else
for(int j = 0;j<level[i].size();j++)
printf(" %d",level[i][j]);


}


}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值