POJ 1094

Sorting It All Out

Time Limit:2000MS    Memory Limit:65536KB    64bit IO Format:%lld & %llu

Description

An ascending sorted sequence of distinct values is one in which some form of a less-than operator is used to order the elements from smallest to largest. For example, the sorted sequence A, B, C, D implies that A < B, B < C and C < D. in this problem, we will give you a set of relations of the form A < B and ask you to determine whether a sorted order has been specified or not.

Input

Input consists of multiple problem instances. Each instance starts with a line containing two positive integers n and m. the first value indicated the number of objects to sort, where 2 <= n <= 26. The objects to be sorted will be the first n characters of the uppercase alphabet. The second value m indicates the number of relations of the form A < B which will be given in this problem instance. Next will be m lines, each containing one such relation consisting of three characters: an uppercase letter, the character "<" and a second uppercase letter. No letter will be outside the range of the first n letters of the alphabet. Values of n = m = 0 indicate end of input.

Output

For each problem instance, output consists of one line. This line should be one of the following three:

Sorted sequence determined after xxx relations: yyy...y.
Sorted sequence cannot be determined.
Inconsistency found after xxx relations.

where xxx is the number of relations processed at the time either a sorted sequence is determined or an inconsistency is found, whichever comes first, and yyy...y is the sorted, ascending sequence.

Sample Input

4 6
A<B
A<C
B<C
C<D
B<D
A<B
3 2
A<B
B<A
26 1
A<Z
0 0

Sample Output

Sorted sequence determined after 4 relations: ABCD.
Inconsistency found after 2 relations.

Sorted sequence cannot be determined.


题意:给出一系列字母的对应关系,给出某一个关系后,

如果能够建立存在且唯一的字母关系,则输出Sorted sequence determined after xxx relations: yyy.  xxx代表使该串成立时的第几个关系

如果串不存在则输出Inconsistency found after xxx relations.

如果所有关系都给出后串仍然不唯一则输出Sorted sequence cannot be determined.


分析:拓扑排序

记录每个字母的入度出度,对于每次输入的关系都进行拓扑排序。

由于要确定存在唯一的串 ,那么每一次贪心法拓扑排序时的队列中的元素一定只有一个,根据此条件判断拓扑排序的唯一性;

如果成环,那么此时一定不存在唯一串;

在关系输入完毕后如果依然没有确定串,那么就无法确定了。


PS:注意答案后面的 ‘.’ ;



///经典拓扑排序
#include<cstring>
#include<string>
#include<iostream>
#include<queue>
#include<cstdio>
#include<algorithm>
#include<map>
#include<cstdlib>
#include<cmath>
#include<vector>

using namespace std;

#define INF 0x3f3f3f3f

int n,m;
int in[30];
vector<int>out[30];
bool g[30][30];

void init()
{
    memset(g,false ,sizeof g);
    for(int i=0; i<=26; i++) out[i].clear(),in[i]=0;
}

int ans[100],cnt;
int toposort()
{
    int ii[30]; ///此处开临时变量保存入度
    memcpy(ii,in,sizeof in);
    cnt=0;
    queue<int>que;
    for(int i=0; i<n; i++)
    {
        if(ii[i]==0) que.push(i);
    }

    int flag=0;
    while(que.size())
    {
        int k=que.front();
        que.pop();
        if(que.size()) flag=1; ///拓扑排序唯一性判断
        ans[cnt++]=k;
        ii[k]--;
        for(int i=0; i<out[k].size(); i++)
        {
            int e=out[k][i];
            ii[e]--;
            if(ii[e]==0)
            {
                que.push(e);
            }
        }
    }

    for(int i=0; i<n; i++)
        if(ii[i]>0)
            return -1;///成环判断
    if(flag) return 0;
    return 1;
}


int main()
{
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        init();
        if(!n&&!m) return 0;
        int ok=0;
        for(int i=0; i<m; i++)
        {
            char s[10];
            scanf("%s",s);
            if(ok) continue;
            if(g[s[0]-'A'][s[2]-'A']==false)
            {
                g[s[0]-'A'][s[2]-'A']==true;
                in[s[0]-'A']++;
                out[s[2]-'A'].push_back(s[0]-'A');
            }
            else continue;
            ok=toposort();
            if(ok==1)
            {
                printf("Sorted sequence determined after %d relations: ",i+1);
                for(int i=n-1; i>=0; i--) printf("%c",ans[i]+'A');
                puts(".");
            }
            else if(ok==-1) printf("Inconsistency found after %d relations.\n",i+1);
        }
        if(!ok) printf("Sorted sequence cannot be determined.\n");
    }
    return 0;
}
 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值