POJ 2155 Matrix (二维线段树)

Matrix

Time Limit:3000MS    Memory Limit:65536KB    64bit IO Format:%I64d & %I64u

Description

Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N).

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a '0' then change it into '1' otherwise change it into '0'). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions.

1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2).
2. Q x y (1 <= x, y <= n) querys A[x, y].

Input

The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case.

The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2 y2", which has been described above.

Output

For each querying output one line, which has an integer representing A[x, y].

There is a blank line between every two continuous test cases.

Sample Input

1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1

Sample Output

1
0
0
1

二维线段树的每一个区间下面都还有一棵线段树,用于这个区间下面存储的区间情况。
块状更新,二维线段树,对于一维,只需要找到指定的区间,然后在二维里面找到那一段进行更新,在查询的时候因为存在一个区间的覆盖更新问题,所以对于每一个一维涉及
到的区间都需要进入查找第二维对应的区间更新情况,查询复杂度 log(n)*log(n)



#include<cstring>
#include<string>
#include<iostream>
#include<queue>
#include<cstdio>
#include<algorithm>
#include<map>
#include<cstdlib>
#include<cmath>
#include<vector>
//#pragma comment(linker, "/STACK:1024000000,1024000000");

using namespace std;

#define INF 0x3f3f3f3f
#define maxn 4005

struct node
{
    int l,r;
    int add;
} T[maxn][maxn];

int n;
void inity(int l,int r,int x,int k)
{
    T[x][k].l=l;
    T[x][k].r=r;
    T[x][k].add=0;
    if(l==r) return ;
    int mid=(l+r)>>1;
    inity(l,mid,x,k<<1);
    inity(mid+1,r,x,k<<1|1);
}

void initx(int l,int r,int k)
{
    inity(1,n,k,1);
    if(l==r) return ;
    int mid=(l+r)>>1;
    initx(l,mid,k<<1);
    initx(mid+1,r,k<<1|1);
}

void updatey(int l,int r,int x,int k)
{
    if(T[x][k].l==l&&T[x][k].r==r)
    {
        T[x][k].add^=1;
        return ;
    }
    int mid=(T[x][k].l+T[x][k].r)>>1;
    if(r<=mid) updatey(l,r,x,k<<1);
    else if(l>mid) updatey(l,r,x,k<<1|1);
    else
    {
        updatey(l,mid,x,k<<1);
        updatey(mid+1,r,x,k<<1|1);
    }
}

void updatex(int l,int r,int s,int e,int k,int y1,int y2)
{
    if(s==l&&e==r)
    {
        updatey(y1,y2,k,1);
        return ;
    }
    int mid=(s+e)>>1;
    if(r<=mid) updatex(l,r,s,mid,k<<1,y1,y2);
    else if(l>mid) updatex(l,r,mid+1,e,k<<1|1,y1,y2);
    else
    {
        updatex(l,mid,s,mid,k<<1,y1,y2);
        updatex(mid+1,r,mid+1,e,k<<1|1,y1,y2);
    }
}

int ans;
void queryy(int p,int x,int k)
{
    ans^=T[x][k].add;
    if(T[x][k].l==p&&T[x][k].r==p)
    {
        return ;
    }
    int mid=(T[x][k].l+T[x][k].r)>>1;
    if(p<=mid) queryy(p,x,k<<1);
    else queryy(p,x,k<<1|1);
}

void queryx(int p,int s,int e,int k,int y)
{
    queryy(y,k,1);
    if(s==p&&e==p)
    {
        return ;
    }
    int mid=(s+e)>>1;
    if(p<=mid) queryx(p,s,mid,k<<1,y);
    else queryx(p,mid+1,e,k<<1|1,y);
}

int main()
{
    int T_T;
    scanf("%d",&T_T);
    while(T_T--)
    {
        int p;
        scanf("%d%d",&n,&p);
        initx(1,n,1);
        while(p--)
        {
            char str[5];
            scanf("%s",str);
            if(str[0]=='C')
            {
                int x1,y1,x2,y2;
                scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
                updatex(x1,x2,1,n,1,y1,y2);
            }
            else
            {
                int a,b;
                scanf("%d%d",&a,&b);
                ans=0;
                queryx(a,1,n,1,b);
                printf("%d\n",ans);
            }
        }
        if(T_T) printf("\n");
    }
    return 0;
}




  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值