HDU 3410 Passing the Message (单调栈)

Passing the Message

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 532    Accepted Submission(s): 331



Problem Description
What a sunny day! Let’s go picnic and have barbecue! Today, all kids in “Sun Flower” kindergarten are prepared to have an excursion. Before kicking off, teacher Liu tells them to stand in a row. Teacher Liu has an important message to announce, but she doesn’t want to tell them directly. She just wants the message to spread among the kids by one telling another. As you know, kids may not retell the message exactly the same as what they was told, so teacher Liu wants to see how many versions of message will come out at last. With the result, she can evaluate the communication skills of those kids.
Because all kids have different height, Teacher Liu set some message passing rules as below:

1.She tells the message to the tallest kid.

2.Every kid who gets the message must retell the message to his “left messenger” and “right messenger”.

3.A kid’s “left messenger” is the kid’s tallest “left follower”.

4.A kid’s “left follower” is another kid who is on his left, shorter than him, and can be seen by him. Of course, a kid may have more than one “left follower”.

5.When a kid looks left, he can only see as far as the nearest kid who is taller than him.

The definition of “right messenger” is similar to the definition of “left messenger” except all words “left” should be replaced by words “right”.

For example, suppose the height of all kids in the row is 4, 1, 6, 3, 5, 2 (in left to right order). In this situation , teacher Liu tells the message to the 3rd kid, then the 3rd kid passes the message to the 1st kid who is his “left messenger” and the 5th kid who is his “right messenger”, and then the 1st kid tells the 2nd kid as well as the 5th kid tells the 4th kid and the 6th kid.
Your task is just to figure out the message passing route.
 

Input
The first line contains an integer T indicating the number of test cases, and then T test cases follows.
Each test case consists of two lines. The first line is an integer N (0< N <= 50000) which represents the number of kids. The second line lists the height of all kids, in left to right order. It is guaranteed that every kid’s height is unique and less than 2^31 – 1 .
 

Output
For each test case, print “Case t:” at first ( t is the case No. starting from 1 ). Then print N lines. The ith line contains two integers which indicate the position of the ith (i starts form 1 ) kid’s “left messenger” and “right messenger”. If a kid has no “left messenger” or “right messenger”, print ‘0’ instead. (The position of the leftmost kid is 1, and the position of the rightmost kid is N)
 

Sample Input
  
  
2 5 5 2 4 3 1 5 2 1 4 3 5
 

Sample Output
  
  
Case 1: 0 3 0 0 2 4 0 5 0 0 Case 2: 0 2 0 0 1 4 0 0 3 0 题意: 说白了就是找每个数左边数值小于且最接近的数和右边数值小于且最接近的数 分析: 典型的单调栈题目,单调减栈,扫两遍处理左值和右值,1A
#include<cstring>
#include<string>
#include<iostream>
#include<queue>
#include<cstdio>
#include<algorithm>
#include<map>
#include<cstdlib>
#include<cmath>
#include<vector>
//#pragma comment(linker, "/STACK:1024000000,1024000000");

using namespace std;

#define INF 0x3f3f3f3f

int a[50005];
int l[50005];
int r[50005];
int s[50005];

int main()
{
    int T;
    int c=1;
    scanf("%d",&T);
    while(T--)
    {
        int n;
        scanf("%d",&n);
        for(int i=1;i<=n;i++ )
        {
            scanf("%d",&a[i]);
        }
        memset(l,0,sizeof l);
        memset(r,0,sizeof r);
        int top=-1;
        a[0]=a[n+1]=INF;
        for(int i=1;i<=n+1;i++)
        {
            int flag=top;
            while(top>=0&&a[i]>a[s[top]])
            {
                if(flag!=top) r[s[top]]=s[top+1];
                top--;
            }
            s[++top]=i;
        }
        top=-1;
        for(int i=n;i>=0;i--)
        {
            int flag=top;
            while(top>=0&&a[i]>a[s[top]])
            {
                if(flag!=top) l[s[top]]=s[top+1];
                top--;
            }
            s[++top]=i;
        }
        printf("Case %d:\n",c++);
        for(int i=1;i<=n;i++)
        {
            printf("%d ",l[i]);
            if(r[i]==n+1) printf("0\n");
            else printf("%d\n",r[i]);
        }
    }
    return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值