HDU 2095 - find your present (2)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 23060    Accepted Submission(s): 9172


Problem Description
In the new year party, everybody will get a "special present".Now it's your turn to get your special present, a lot of presents now putting on the desk, and only one of them will be yours.Each present has a card number on it, and your present's card number will be the one that different from all the others, and you can assume that only one number appear odd times.For example, there are 5 present, and their card numbers are 1, 2, 3, 2, 1.so your present will be the one with the card number of 3, because 3 is the number that different from all the others.
 

Input
The input file will consist of several cases. 
Each case will be presented by an integer n (1<=n<1000000, and n is odd) at first. Following that, n positive integers will be given in a line, all integers will smaller than 2^31. These numbers indicate the card numbers of the presents.n = 0 ends the input.
 

Output
For each case, output an integer in a line, which is the card number of your present.
 

Sample Input
  
  
5 1 1 3 2 2 3 1 2 1 0
 

Sample Output
  
  
3 2
Hint
Hint
use scanf to avoid Time Limit Exceeded
 

Author
8600
 

Source
 

Recommend
8600   |   We have carefully selected several similar problems for you:   2097  2099  2096  2094  1008 


简单地说,就是输入奇数个数字,找出那个成单的数字,下面是两种思路(因为感觉用亦或实在有点反人类思维……所以你就用刚学的STL整了一下)

①使用map,一一对应:
#include<cstdio>
#include<map>
using namespace std;
int main()
{
    int n;
    while(scanf("%d",&n) && n>0){
        map<int,int> num;
        for(int i=0;i<n;i++){
            int temp;scanf("%d",&temp);
            if(!num.count(temp)) num[temp]=0;
            num[temp]++;
        }
        for(map<int,int>::iterator i=num.begin();i!=num.end();i++){
            if((i->second)%2 != 0) {printf("%d\n",i->first);break;}
        }
    }
    return 0;
}

②使用sort快排:
#include<stdio.h>
#include<algorithm>
using namespace std;
int main()
{
	int i,n;while(scanf("%d",&n) && n>0){
		int *num=(int *)malloc(n*sizeof(int));
		for(i=0;i<n;i++) scanf("%d",&num[i]);
		sort(num,num+n);
		for(i=0;i<n;i+=2) if(num[i]!=num[i+1]) {printf("%d\n",num[i]);break;}
	}
}
一般来说,最好在找到那个数字之后就break,要不然还是会time limit exceeded……

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值