Description
某国有N个村子,M条道路,为了实现“村村通工程”现在要”油漆”N-1条道路(因为某些人总是说该国所有的项目全是从国外进口来的,只是漆上本国的油漆罢了),因为“和谐”是此国最大的目标和追求,以致于对于最小造价什么的都不在乎了,只希望你所选出来的最长边与最短边的差越小越好。
Input
第一行给出一个数字TOT,代表有多少组数据,Tot<=6
对于每组数据,首先给出N,M
下面M行,每行三个数a,b,c代表a村与b的村道路距离为c.
Output
输出最小差值,如果无解输出”-1”.
Sample Input
1
4 5
1 2 3
1 3 5
1 4 6
2 4 6
3 4 7
Sample Output
1
Data Constraint
Hint
【样例解释】
选择1-4,2-4,3-4这三条边.
【数据范围】
1:2 ≤ n ≤ 100 and 0 ≤ m ≤ n(n − 1)/2
2:每条边的权值小于等于10000
3:保证没有自环,没有重边
//written by zzy
题目大意:
求一颗最大边-最小边的值最小的生成树
题解:
考虑暴力枚举最小边,跑最小生成树,统计答案。
#include<iostream>
#include<cmath>
#include<cstdio>
#include<algorithm>
#define N 105
#define M 10005
#define Max 100000007
using namespace std;
int i,j,n,m,k,ans,p,u,tot;
int fa[N];
struct E{
int x,y,z;
}l[M];
bool cmp(E a,E b){
return a.z<b.z;
}
int get(int x) {
if (fa[x]==x) return x;
return fa[x]=get(fa[x]);
}
void merge(int x,int y) {
fa[get(y)]=get(x);
}
bool check()
{
int num=get(1);
for (int i=1;i<=n;i++)
if (get(i)!=num) return false;
return true;
}
int main()
{
scanf("%d",&tot);
for (u=1;u<=tot;u++)
{
ans=Max;
scanf("%d%d",&n,&m);
for (i=1;i<=m;i++)
scanf("%d%d%d",&l[i].x,&l[i].y,&l[i].z);
sort(l+1,l+m+1,cmp);
for (i=1;i<=m;i++)
{
for (k=1;k<=n;k++) fa[k]=k;
for (j=i;j<=m;j++)
if (get(l[j].x)!=get(l[j].y))
{
merge(l[j].x,l[j].y);
p=j;
}
if (check()) ans=min(ans,l[p].z-l[i].z);
}
if (ans!=Max) printf("%d\n",ans);
else printf("%d\n",-1);
}
}