7-31 字符串循环左移 (20分)
输入一个字符串和一个非负整数N,要求将字符串循环左移N次。
输入格式:
输入在第1行中给出一个不超过100个字符长度的、以回车结束的非空字符串;第2行给出非负整数N。
输出格式:
在一行中输出循环左移N次后的字符串。
输入样例:
Hello World!
2
输出样例:
llo World!He
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <string>
using namespace std;
int main(){
int n,i,j;
string str;
string red;
getline(cin,str);
j = str.size();
cin>>n;
for(i=0;i<n;i++){//进行n次交换
red = str[0];//将str首字母保存
str.erase(str.begin());//删除str首字母
str.insert(j-1,red);//将str首字母放入str尾部
}
cout << str;
return 0;
}