ACdream1734 Can you make a water problem?(贪心)

Problem Description
Losanto want to make a water problem. But he have no idea….
Then he thought a problem: A bus arrived at a station, and there were x persons got off the bus, then y persons got on the bus. And there were r persons(include the driver) on the bus before the bus arrived at next station. How many person on the bus initially? The driver can’t get on or off the bus. There is only 1 driver in the bus.
But if the x=8 , y=5 r=4, there are something wrong in the problem. After got on 5 persons and there are 4 persons rest…What a pity! Losanto give you x, y, r want know whether the problem is OK.
Of course few buses has only one station, so there are n stations.
Now give you x and y for every station, and there is only one person (the driver) rest after the last station. Can you find a suitable order for the station to make the problem OK?
Input

There are several cases.

For each case, First line there is a n, indicate n stations. Then n lines followed, each line has two numbers xi and yi. To make the problem easier, we guarantee that xi>=yi.( 0<n<100000  0<=xi,yi<1000000)
Output
For each cases, output one line with “Yes” (if you can make an OK order) or “No” (if you can’t).
Sample Input
2
5 0
7 4
2
5 2
3 3
Sample Output
Yes
No


下午没有想到正确的贪心策略,跑偏了再见,自己想的太复杂了。。


有n个站 每个站x人下,y人上车,问你情况是否可行。


保证车上人数大于等于下车人数就好


AC代码:


#include "iostream"
#include "cstdio"
#include "cstring"
#include "algorithm"
using namespace std;
const int maxn = 100005;
typedef long long ll;
int n;
ll tot;
struct node
{
	/* data */
	int x, y;
}a[maxn];
bool cmp(node a, node b)
{
	return a.x - a.y > b.x - b.y;
}
bool judge()
{
	for(int i = 0; i < n; ++i) {
		if(tot < a[i].x) return false;
		tot -= a[i].y;
	}
	return true;
}
int main(int argc, char const *argv[])
{
	while(scanf("%d", &n) != EOF) {
		tot = 0;
		for(int i = 0; i < n; ++i) {
			scanf("%d%d", &a[i].x, &a[i].y);
			tot += (a[i].x - a[i].y);
			a[i].y = a[i].x - a[i].y;
		}
		sort(a, a + n, cmp);
		if(judge()) printf("Yes\n");
		else printf("No\n");
	}
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值