ZOJ3818 Pretty Poem(暴力)

Poetry is a form of literature that uses aesthetic and rhythmic qualities of language. There are many famous poets in the contemporary era. It is said that a few ACM-ICPC contestants can even write poetic code. Some poems has a strict rhyme scheme like "ABABA" or "ABABCAB". For example, "niconiconi" is composed of a rhyme scheme "ABABA" with A = "ni" and B = "co".

More technically, we call a poem pretty if it can be decomposed into one of the following rhyme scheme: "ABABA" or "ABABCAB". The symbol AB and C are different continuous non-empty substrings of the poem. By the way, punctuation characters should be ignored when considering the rhyme scheme.

You are given a line of poem, please determine whether it is pretty or not.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

There is a line of poem S (1 <= length(S) <= 50). S will only contains alphabet characters or punctuation characters.

Output

For each test case, output "Yes" if the poem is pretty, or "No" if not.

Sample Input
3
niconiconi~
pettan,pettan,tsurupettan
wafuwafu
Sample Output
Yes
Yes
No


问你一个字符串是不是pretty,即是否满足"ABABA" "ABABCAB".


下午还想kmp使劲搞 没敢写= =


看了题解才体会到 string强大省事~


AC代码:


#include "iostream"
#include "cstdio"
#include "cstring"
#include "algorithm"
#include "string"
using namespace std;
const int maxn = 55;
int main(int argc, char const *argv[])
{
	int t;
	scanf("%d", &t);
	while(t--) {
		char str[maxn];
		scanf("%s", str);
		int len = strlen(str);
		string s;
		for(int i = 0; i < len; ++i)
			if(isupper(str[i]) || islower(str[i])) s += str[i];
		len = s.length();
		bool flag = false;
		for(int i = 1; i < len/ 2 && !flag; ++i)
			for(int j = 1; j < len/ 2 && !flag; ++j) {
				string A = s.substr(0, i);
				string B = s.substr(i, j);
				if(A == B) continue;
				if(A + B + A + B + A == s) {
					flag = true;
					break;
				}
				if(len - (i + j) * 3 > 0) {
					string AB = A + B;
					string C = s.substr(2 * (i + j), len - (i + j) * 3);
					if(A == C || B == C) continue;
					if(AB + AB + C + AB == s) {
						flag  = true;
						break;
					}
				}
			}
		if(flag) printf("Yes\n");
		else printf("No\n");
	}
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值