Description
You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides.
Is an escape possible? If yes, how long will it take?
Is an escape possible? If yes, how long will it take?
Input
The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size).
L is the number of levels making up the dungeon.
R and C are the number of rows and columns making up the plan of each level.
Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a '#' and empty cells are represented by a '.'. Your starting position is indicated by 'S' and the exit by the letter 'E'. There's a single blank line after each level. Input is terminated by three zeroes for L, R and C.
L is the number of levels making up the dungeon.
R and C are the number of rows and columns making up the plan of each level.
Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a '#' and empty cells are represented by a '.'. Your starting position is indicated by 'S' and the exit by the letter 'E'. There's a single blank line after each level. Input is terminated by three zeroes for L, R and C.
Output
Each maze generates one line of output. If it is possible to reach the exit, print a line of the form
where x is replaced by the shortest time it takes to escape.
If it is not possible to escape, print the line
Escaped in x minute(s).
where x is replaced by the shortest time it takes to escape.
If it is not possible to escape, print the line
Trapped!
Sample Input
3 4 5 S.... .###. .##.. ###.# ##### ##### ##.## ##... ##### ##### #.### ####E 1 3 3 S## #E# ### 0 0 0
Sample Output
Escaped in 11 minute(s). Trapped!
三维迷宫,用一个三维数组保存然后跟二维一样的板子。S是起点E是终点,通过.可以去另一张图,能到达E输出步数,不能到达E则
输出Trapped!
AC代码:
#include "iostream"
#include "cstdio"
#include "cstring"
#include "algorithm"
using namespace std;
typedef class
{
public:
int l, r, c;
int depth;
}SE;
SE s, e;
bool maze[40][40][40];
int ans;
bool bfs(int k, int i, int j)
{
bool vis[40][40][40] = {false};
SE queue[30000];
int head, tail;
queue[head = 0].l = k;
queue[tail = 0].r = i;
queue[0].c = j;
queue[tail++].depth = 0;
vis[k][i][j] = true;
while(head < tail) {
SE x = queue[head++];
if(x.l == e.l && x.r == e.r && x.c == e.c) {
ans = x.depth;
return true;
}
if(maze[x.l][x.r][x.c - 1] && !vis[x.l][x.r][x.c - 1]) {
vis[x.l][x.r][x.c - 1] = true;
queue[tail].l = x.l;
queue[tail].r = x.r;
queue[tail].c = x.c - 1;
queue[tail++].depth = x.depth + 1;
}
if(maze[x.l][x.r - 1][x.c] && !vis[x.l][x.r - 1][x.c]) {
vis[x.l][x.r - 1][x.c] = true;
queue[tail].l = x.l;
queue[tail].r = x.r - 1;
queue[tail].c = x.c;
queue[tail++].depth = x.depth + 1;
}
if(maze[x.l][x.r][x.c + 1] && !vis[x.l][x.r][x.c + 1]) {
vis[x.l][x.r][x.c + 1] = true;
queue[tail].l = x.l;
queue[tail].r = x.r;
queue[tail].c = x.c + 1;
queue[tail++].depth = x.depth + 1;
}
if(maze[x.l][x.r + 1][x.c] && !vis[x.l][x.r + 1][x.c]) {
vis[x.l][x.r + 1][x.c] = true;
queue[tail].l = x.l;
queue[tail].r = x.r + 1;
queue[tail].c = x.c;
queue[tail++].depth = x.depth + 1;
}
if(maze[x.l - 1][x.r][x.c] && !vis[x.l - 1][x.r][x.c]) {
vis[x.l - 1][x.r][x.c] = true;
queue[tail].l = x.l - 1;
queue[tail].r = x.r;
queue[tail].c = x.c;
queue[tail++].depth = x.depth + 1;
}
if(maze[x.l + 1][x.r][x.c] && !vis[x.l + 1][x.r][x.c]) {
vis[x.l + 1][x.r][x.c] = true;
queue[tail].l = x.l + 1;
queue[tail].r = x.r;
queue[tail].c = x.c;
queue[tail++].depth = x.depth + 1;
}
}
return false;
}
int main(int argc, char const *argv[])
{
int L, R, C;
while(cin >> L >> R >> C) {
if(!L && !R && !C)
break;
memset(maze, false, sizeof(maze));
for(int k = 1; k <= L; ++k)
for(int i = 1; i <= R; ++i)
for(int j = 1; j <= C; ++j) {
char temp;
cin >> temp;
if(temp == '.')
maze[k][i][j] = true;
if(temp == 'S' ) {
maze[k][i][j] = true;
s.l = k;
s.r = i;
s.c = j;
}
if(temp == 'E') {
maze[k][i][j] = true;
e.l = k;
e.r = i;
e.c = j;
}
}
if(bfs(s.l, s.r, s.c))
cout << "Escaped in " << ans << " minute(s)." << endl;
else
cout << "Trapped!" << endl;
}
return 0;
}