POJ1745 Divisibility(dp)

Divisibility
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 11053 Accepted: 3953

Description

Consider an arbitrary sequence of integers. One can place + or - operators between integers in the sequence, thus deriving different arithmetical expressions that evaluate to different values. Let us, for example, take the sequence: 17, 5, -21, 15. There are eight possible expressions: 17 + 5 + -21 + 15 = 16 
17 + 5 + -21 - 15 = -14 
17 + 5 - -21 + 15 = 58 
17 + 5 - -21 - 15 = 28 
17 - 5 + -21 + 15 = 6 
17 - 5 + -21 - 15 = -24 
17 - 5 - -21 + 15 = 48 
17 - 5 - -21 - 15 = 18 
We call the sequence of integers divisible by K if + or - operators can be placed between integers in the sequence in such way that resulting value is divisible by K. In the above example, the sequence is divisible by 7 (17+5+-21-15=-14) but is not divisible by 5. 

You are to write a program that will determine divisibility of sequence of integers. 

Input

The first line of the input file contains two integers, N and K (1 <= N <= 10000, 2 <= K <= 100) separated by a space. 
The second line contains a sequence of N integers separated by spaces. Each integer is not greater than 10000 by it's absolute value. 

Output

Write to the output file the word "Divisible" if given sequence of integers is divisible by K or "Not divisible" if it's not.

Sample Input

4 7
17 5 -21 15

Sample Output

Divisible



给一个长度为n的数组,自己可以加减运算,问能不能被k整除。


读入的时候处理,dp[i][j] == 1代表可以被k整除。


状态转移方程:dp[i][(j + num[i]) % k],dp[i][(k + j - num[i]) % k] ,表示加上或减去第i个数,所得数取模能否为j。


AC代码:


#include "iostream"
#include "cstdio"
#include "cstring"
#include "algorithm"
using namespace std;
const int maxn = 1e4 + 5;
int main(int argc, char const *argv[])
{
	int n, k;
	while(cin >> n >> k) {
		int dp[maxn][101] = {0}, num[maxn];
		for(int i = 0; i < n; ++i) {
			cin >> num[i];
			if(num[i] < 0) num[i] = -num[i];
			num[i] %= k;
		}
		dp[0][num[0]] = 1;
		for(int i = 1; i < n; ++i)
			for(int j = 0; j <= k; ++j)
				if(dp[i - 1][j]) {
					dp[i][(j + num[i]) % k] = 1;
					dp[i][(k + j - num[i]) % k] = 1;
				}
		if(dp[n - 1][0]) cout << "Divisible" << endl;
		else cout << "Not divisible" << endl;
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值