BestCoder Round #43B HDOJ5265 pog loves szh II(脑洞)

46 篇文章 0 订阅
29 篇文章 0 订阅

pog loves szh II

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2346    Accepted Submission(s): 677


Problem Description
Pog and Szh are playing games.There is a sequence with  n  numbers, Pog will choose a number A from the sequence. Szh will choose an another number named B from the rest in the sequence. Then the score will be  (A+B)  mod  p .They hope to get the largest score.And what is the largest score?
 

Input
Several groups of data (no more than  5  groups, n1000 ).

For each case: 

The following line contains two integers, n(2n100000) p(1p2311)

The following line contains  n  integers  ai(0ai2311)
 

Output
For each case,output an integer means the largest score.
 

Sample Input
  
  
4 4 1 2 3 0 4 4 0 0 2 2
 

Sample Output
  
  
3 2
 



题目链接:点击打开链接

对每个读入的数去p的模, 排序下, 扫一遍数组, 对每个数, 从后向前遍历, 直到等于当前数时break掉, 如果没有找到最大, 那就用最后一

个数加前面的求最大即可.

AC代码:

#include "iostream"
#include "cstdio"
#include "cstring"
#include "algorithm"
#include "queue"
#include "stack"
#include "cmath"
#include "utility"
#include "map"
#include "set"
#include "vector"
#include "list"
#include "string"
#include "cstdlib"
using namespace std;
typedef long long ll;
#define X first
#define Y second
const int MOD = 1e9 + 7;
const int INF = 0x3f3f3f3f;
const int MAXN = 1e5 + 5;
ll n, p, a[MAXN];
int main(int argc, char const *argv[])
{
	while(scanf("%lld%lld", &n, &p) != EOF) {
		for(int i = 0; i < n; ++i) {
			scanf("%lld", &a[i]);
			a[i] %= p;
		}
		sort(a, a + n);
		int j = n - 1;
		ll ans = 0;
		for(int i = 0; i < n; ++i) {
			while(j > i && a[j] + a[i] >= p) --j;
			if(j == i) break;
			ans = max(ans, a[i] + a[j]);
		}
		for(int i = 0; i < n - 1; ++i)
			ans = max(ans, (a[i] + a[n - 1]) % p);
		printf("%lld\n", ans);
	}
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值