a+b(3)



Description

Your task is to Calculate a + b.

Input

There are multiple test cases. Each test case contains only one line. Each line consists of a pair of integers a and b1=< a,b <=1016, separated by a space. Input is followed by a single line with a = 0, b = 0, which should not be processed.

Output

For each pair of input integers a and b you should output the sum of a and b in one line, and with one line of output for each line in input.

Sample Input

1 5
10 20
10000000000000000 10000000000000000
0 0

Sample Output

6
30
20000000000000000

HINT

#include <stdio.h>
 #include <string.h> 
int main(){
    char str1[1001], str2[1001];
    int  i, len_str1, len_str2, len_max, num = 1, k;     
    while(scanf("%s", str1)&& scanf("%s",str2)!=EOF){
        if(str1[0]=='0'&&str2[0]=='0') continue;
        int a[1001] = {0}, b[1001] = {0}, c[1001] = {0};          
        len_str1 = strlen(str1);
        for(i = 0; i <= len_str1 - 1; ++i)
            a[i] = str1[len_str1 - 1 - i] - '0';         
        len_str2 =  strlen(str2);
        for(i = 0; i <= len_str2 - 1; ++i)
            b[i] = str2[len_str2 - 1 - i] - '0';       
    if(len_str1 > len_str2)          
      len_max = len_str1;       
       else
            len_max = len_str2;      
     k = 0;
        for(i = 0; i <= len_max - 1; ++i){     
         c[i] = (a[i] + b[i] + k) % 10;     
             k = (a[i] + b[i] + k) / 10;      
         }
        if(k != 0)
        c[len_max] = 1; 
   if(c[len_max] == 1)            
  printf("1");
        for(i = len_max - 1; i >= 0; --i){          
    printf("%d", c[i]);      
      }
        printf("\n");       
           
   }
    return 0;
}

注意如何将char类型转换成int类型


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值