Description
Input
输入包含不超过10000 组数据。每组数据包含6个整数r1, c1, r2, c2, r3, c3 (1<=r1, c1, r2, c2, r3, c3<=8). 三个格子A, B, C保证各不相同。
Output
对于每组数据,输出测试点编号和最少步数。
Sample Input
1 1 8 7 5 6
1 1 3 3 2 2
Sample Output
Case 1: 7
Case 2: 3
HINT
Source
本来这题应该用bfs解决,但自己bfs还不熟练就使用了模拟的方法
大致思路分为三点在一条斜率为1的线上和不在一条斜率为1的线上,具体方法实现在代码中
#include<iostream>
using namespace std;
bool check(int x1,int y1,int x2,int y2,int a,int b)
{
if(((x1-x2)==(y1-y2)&&(x1-a)==(y1-b))||((x1-x2)==(y2-y1)&&(x1-a)==(b-y1))) return true;
else return false;
}
bool check1(int x1,int y1,int x2,int y2,int a,int b)
{
if((a<min(x1,x2))||a>max(x1,x2)||b<min(y1,y2)||b>max(y1,y2)) return false;
else return true;
}
main()
{
int x1,y1,x2,y2,a,b,qun=1;
while(~scanf("%d%d%d%d%d%d",&x1,&y1,&x2,&y2,&a,&b))
{
int x,y;
if(x2>x1)x=x2-x1;
else x=x1-x2;
if(y2>y1)y=y2-y1;
else y=y1-y2;
if(check(x1,y1,x2,y2,a,b)&&check1(x1,y1,x2,y2,a,b))
printf("Case %d: %d\n",qun++,max(x,y)+1);
else printf("Case %d: %d\n",qun++,max(x,y));
}
}
bfs做法
#include <stdio.h>
#include <queue>
#include <algorithm>
using namespace std;
#include <string.h>
#include <stdlib.h>
int map[205][205];
int vis[205][205];
int dir[8][2]={{1,0},{-1,0},{0,1},{0,-1},{1,-1},{1,1},{-1,1},{-1,-1}};//周围的八个方向跳
int s1,e1,x2,y2;
struct node
{
int x,y;
int step;
}
;
bool check(int x,int y) //检查是否符合条件
{
if(x>8 || y>8 ||x<1 ||y<1 )
return 1;
if(x==x2 &&y==y2)
return 1;
if(vis[x][y])
return 1;
return 0;
}
int bfs(int x,int y)
{
int i;
queue<node>q;
node st,ed;
st.x=x;
st.y=y;
st.step=0;
q.push(st);
while(!q.empty())
{
st=q.front();
q.pop();
if(st.x==s1 &&st.y==e1)
return st.step; // 返回最小步数
for(i=0;i<8;i++)
{
ed.x=st.x+dir[i][0];
ed.y=st.y+dir[i][1];
if(check(ed.x,ed.y))
continue;
ed.step=st.step+1;
vis[ed.x][ed.y]=1;
q.push(ed);
}
}
}
int main()
{
int s,e,i,j;
int Case=0;
while(scanf("%d%d%d%d%d%d",&s,&e,&s1,&e1,&x2,&y2)!=EOF)
{
memset(vis,0,sizeof(vis));
vis[s][e]=1;
int ans=bfs(s,e);
printf("Case %d: ",++Case);
printf("%d\n",ans);
}
return 0;
}