poj 2785 4 Values whose Sum is 0

<p class="pst">Description</p><div class="ptx" lang="en-US">The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n . </div><p class="pst">Input</p><div class="ptx" lang="en-US">The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 2<sup><span style="font-size:12px;">28</span></sup> ) that belong respectively to A, B, C and D . </div><p class="pst">Output</p><div class="ptx" lang="en-US">For each input file, your program has to write the number quadruplets whose sum is zero. </div><p class="pst">Sample Input</p><pre class="sio">6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
26 -38 -10 62
-32 -54 -6 45

 

Sample Output

5

Hint

Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32, -54, 56, 30).
本题采用二分的思路,但由于数据规模较大,仍很容易超时,这里贴一个超时的代码,暂时还没优化成功
#include<iostream>
#include<stdio.h>
#include<cstring>
#include<algorithm>

using namespace std;
int a[4005],b[4005],c[4005],d[4005],x[16000005];
main()
{
    freopen("in.txt","r",stdin);
    int n;
    while(~scanf("%d",&n))
    {
        for(int i=0;i<n;i++)
        {
            scanf("%d%d%d%d",&a[i],&b[i],&c[i],&d[i]);
        }
        int t=0;
        for(int i=0;i<n;i++)
        for(int j=0;j<n;j++)
        x[t++]=a[i]+b[j];
        sort(x,x+t);
        int ans=0;
        for(int i=0;i<n;i++)
        for(int j=0;j<n;j++)
        {
            int y=-c[i]-d[j];
            for(int k=0;k<t;k++)
            {
                if(y==x[k])ans++;
                if(y<x[k])break;
            }
        }
        printf("%d\n",ans);
    }
}

本题借助自制哈希表可有效解决,这里先贴上代码(已AC),由于暂时对哈希表不了解,这里只是照着葫芦画瓢,具体哈希中问题有待进一步研究学习
#include<iostream>
#include<stdio.h>
#define MAX 1000000000
#define size 20345677
#define key 745
int hash[size],sum[size];
int a[4040],b[4040],c[4040],d[4040];
int insert(int num)
{
	int tmp=num;
	num=(num+MAX)%size;
	while(hash[num]!=MAX && hash[num]!=tmp)
		num=(num+key)%size;
	hash[num]=tmp;
	sum[num]++;
}
int find(int num)
{
	int tmp=num;
	num=(num+MAX)%size;
	while(hash[num]!=MAX && hash[num]!=tmp)
		num=(num+key)%size;
	if(hash[num]==MAX)
		return 0;
	else
		return sum[num];
}
int main()
{
    //freopen("in.txt","r",stdin);
	int n;
	while(~scanf("%d",&n)){
	for(int i=0;i<n;i++)
		scanf("%d %d %d %d",&a[i],&b[i],&c[i],&d[i]);
	for(int i=0;i<size;i++)
		hash[i]=MAX;
	for(int i=0;i<n;i++)
		for(int j=0;j<n;j++)
			insert(a[i]+b[j]);
	int ans=0;
	for(int i=0;i<n;i++)
		for(int j=0;j<n;j++)
			ans=ans+find(-c[i]-d[j]);
    printf("%d\n",ans);
}
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值