uvalive 3027



Description

Download as PDF

A very big corporation is developing its corporative network. In the beginning each of the N enterprises of the corporation, numerated from 1 to N, organized its own computing and telecommunication center. Soon, for amelioration of the services, the corporation started to collect some enterprises in clusters, each of them served by a single computing and telecommunication center as follow. The corporation chose one of the existing centers I (serving the cluster A) and one of the enterprises J in some cluster B (not necessarily the center) and link them with telecommunication line. The length of the line between the enterprises I and J is |I � J|(mod 1000). In such a way the two old clusters are joined in a new cluster, served by the center of the old cluster B. Unfortunately after each join the sum of the lengths of the lines linking an enterprise to its serving center could be changed and the end users would like to know what is the new length. Write a program to keep trace of the changes in the organization of the network that is able in each moment to answer the questions of the users.

Input

Your program has to be ready to solve more than one test case. The first line of the input file will contains only the number T of the test cases. Each test will start with the number N of enterprises (5≤N≤20000). Then some number of lines (no more than 200000) will follow with one of the commands:
E I � asking the length of the path from the enterprise I to its serving center in the moment;
I I J � informing that the serving center I is linked to the enterprise J.
The test case finishes with a line containing the word O. The I commands are less than N.

Output

The output should contain as many lines as the number of E commands in all test cases with a single number each � the asked sum of length of lines connecting the corresponding enterprise with its serving center.

Sample Input

1
4
E 3
I 3 1
E 3
I 1 2
E 3
I 2 4
E 3
O

Sample Output

0
2
3
5
题意:这英语给我看晕了,不说了
思路:传统的并查集路径压缩,类似于那道经典的食物链问题,注意压缩的方法即可
#include <iostream>
#include <stdio.h>
#include <cstring>
using namespace std;
int f[50000],len[50000];
int n;
int find(int x)
{
	if(x==f[x])
		return x;
	int tmp=f[x];
	f[x]=find(f[x]);
	len[x]=(len[x]+len[tmp]);
	return f[x];
}
int ab(int x,int y)
{
	return x>y?x-y:y-x;
}
int merge(int x,int y)
{
	int xx=find(x);
	int yy=find(y);
    if(xx==yy)
    	return 1;
    else
    {
    	f[xx]=yy;
    	len[xx]=(len[y]-len[x]+ab(x,y)%1000);
    	find(x);
    	return 0;
    }

}
int main()
{
	//freopen("in.txt","r",stdin);
	int t;
	while(scanf("%d",&t)!=EOF)
	{
    while(t--)
    {
		scanf("%d",&n);
		for(int i=0;i<=20008;i++)
		{
			f[i]=i;
			len[i]=0;
		}
		char g[2];
		int x,y;
        while(scanf("%s",g)!=EOF)
        {
                if(g[0]=='O')
                break;

				if(g[0]=='E')
				{
					scanf("%d",&x);
					find(x);
					printf("%d\n",len[x]);
				}
				else
				{
					scanf("%d%d",&x,&y);
					merge(x,y);
				}
		}
	}
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值