dfs hdu 1016 Prime Ring Problem

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime. 

Note: the number of first circle should always be 1. 

 
Input
n (0 < n < 20). 
Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order. 

You are to write a program that completes above process. 

Print a blank line after each case. 
Sample Input
6
8
Sample Output
Case 1:
1 4 3 2 5 6
1 6 5 2 3 4


Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2

1 6 7 4 3 8 5 2

题意概况:给你一个数n,问从1到n这n个数如何排序才能让每两个相邻的相加结果都是素数,输出所有符合条件的排序。

解题思路:通过题意可以知道第一个数肯定是1,把1存入数组的一个位置,然后让1进入深搜函数,从2到n找到符合条件的数,把这个数标记为取过,然后把这个数存入数组的第二个位置,接着让这个数进入函数,直到数组位置填满输出数组,然后寻找是否有新的数组符合条件。

代码:

#include<stdio.h>
#include<string.h>
int n,t=0,a[1000],book[1000];
int prime(int m);
void p(int s);
void dfs(int s);
int main()

{
	int i,j,k,l;
	
	while(scanf("%d",&n)!=EOF)
	{
		t++;
		printf("Case %d:\n",t);
		a[1]=1;
		book[1]=1;
		dfs(1);
		printf("\n");
	}	
	return 0;
}
int prime(int m)
{
	int i;
	if(m==1)
		return 0;
	for(i=2;i<m;i++)
	{
		if(m%i==0)
			return 0;
	}
	return 1;
}
void p(int s)
{
	int i,j;
	printf("%d",a[1]);
		for(i=2;i<=s;i++)
		{
			printf(" %d",a[i]);
		}
		printf("\n");
	
	return ;
}
void dfs(int s)
{
	int i,j;
	if(n==s&&prime(a[s]+1)==1)
	{
		p(s);	
	}
	for(i=2;i<=n;i++)
	{
		if(book[i]==0&&prime(a[s]+i)==1)//注意s和i不要搞混了
		{
			book[i]=1;
			a[s+1]=i;
			dfs(s+1);
			book[i]=0;
			
		}
	}
	return ;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值