hdu 1003 Max Sum


        Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5
Sample Output
Case 1:
14 1 4

Case 2:
7 1 6

题意概括:找出所给数列的最大子集和,并输出开始坐标和结束坐标。



解题思路:初始sum,max的值为一个数,从第二个数开始遍历每一个数,依次加上sum,若sum的值小于0,然所找的子集开始位置更新,因为sum小于0无论后面如何加都不会是最大值,每次加过之后与max比较大小,如果大于则证明加的这个数可用,让子集的末尾坐标更新。


代码:

#include<stdio.h>

int main()
{
	int T,t,i,j,k,n,a[101000],e=0,f,p,max,sum,o;
	scanf("%d",&T);
	f=T;
	while(T--)
	{
		e++;
		scanf("%d",&n);
		for(i=0;i<n;i++)
		{
			scanf("%d",&a[i]);
		}
		max=a[0];
		sum=a[0];
		o=1;
		p=1;
		t=1;
		for(i=1;i<n;i++)
		{
			//printf("%d %d\n",sum,max);
			if(sum<0)
			{
				sum=0;
				t=i+1;
				//t=o;
			}
			sum+=a[i];
			if(sum>max)
			{
				max=sum;
				p=i+1;
				o=t;
			}
		
		}
		//printf("f%d\n",f);
		//if(o>p)
		//o=p;
		printf("Case %d:\n",e);printf("%d ",max);
		printf("%d %d\n",o,p);
		if(e!=f)
		{
			printf("\n");
		}
		
	}
	
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值