Problem B: 平面上的点和线——Point类、Line类 (VII)

Description

在数学上,平面直角坐标系上的点用X轴和Y轴上的两个坐标值唯一确定,两点确定一条线段。现在我们封装一个“Point类”和“Line类”来实现平面上的点的操作。
根据“append.cc”,完成Point类和Line类的构造方法和show()方法,输出各Line对象和Point对象的构造和析构次序。
接口描述:
Point::showCounter()方法:按格式输出当前程序中Point对象的计数。
Point::showSum()方法:按格式输出程序运行至当前存在过的Point对象总数。
Line::showCounter()方法:按格式输出当前程序中Line对象的计数。
Line::showSum()方法:按格式输出程序运行至当前存在过的Line对象总数。

Input

输入的第一行为N,表示后面有N行测试样例。
每行为两组坐标“x,y”,分别表示线段起点和终点的x坐标和y坐标,两组坐标间用一个空格分开,x和y的值都在double数据范围内。

Output

输出格式见sample。
C语言的输入输出被禁用。

Sample Input

40,0 1,11,1 2,32,3 4,50,1 1,0

Sample Output

Current : 3 points.In total : 3 points.Current : 6 lines.In total : 6 lines.Current : 17 points.In total : 17 points.Current : 6 lines.In total : 7 lines.Current : 15 points.In total : 17 points.Current : 6 lines.In total : 8 lines.Current : 17 points.In total : 21 points.Current : 6 lines.In total : 9 lines.Current : 15 points.In total : 21 points.Current : 6 lines.In total : 10 lines.Current : 17 points.In total : 25 points.Current : 6 lines.In total : 11 lines.Current : 15 points.In total : 25 points.Current : 6 lines.In total : 12 lines.Current : 17 points.In total : 29 points.Current : 6 lines.In total : 13 lines.Current : 15 points.In total : 29 points.Current : 9 lines.In total : 17 lines.Current : 21 points.In total : 37 points.Current : 13 lines.In total : 21 lines.Current : 21 points.In total : 45 points.

HINT

Append Code

append.cc


#include<bits/stdc++.h>
using namespace std;
class Point
{
private:
    double x,y;
    static int Counter1;
    static int sum1;
public:
    Point():x(0),y(0)
    {
        Counter1++;
        sum1++;
    }
    Point(double a,double b)
    {
        x=a;
        y=b;
        Counter1++;
        sum1++;
    }
    Point(const Point&a)
    {
        x=a.x;
        y=a.y;
        sum1++;
        Counter1++;
    }
    ~Point()
    {
        Counter1--;
    }
    static void showCounter()
    {
        cout<<"Current : "<<Counter1<<" points."<<endl;
    }
    static void showSum()
    {
        cout<<"In total : "<<sum1<<" points."<<endl;
    }
    void cinx(double a)
    {
        x=a;
        //sum1++;
    }
    void ciny(double a)
    {
        y=a;
    }
    void sum111()
    {
        sum1--;
    }
};
class Line
{
private:
    Point a,b;
    static int Counter2;
    static int sum2;
public:
    Line():a(0,0),b(0,0)
    {
        Counter2++;
        sum2++;
    }
    Line(Line& c)
    {
        a=c.a;
        b=c.b;
        sum2++;
        Counter2++;
    }
    void gLine(double x1,double x2,double x3,double x4)
    {
        a.cinx(x1);
        a.ciny(x2);
        b.cinx(x3);
        b.ciny(x4);
        //sum2++;
        //Counter2++;
    }
    Line(Point &x,Point &y)
    {
        a=x;
        b=y;
        Counter2++;
        sum2++;
        //a.sum111();
    }
    ~Line()
    {
        Counter2--;
    }
    static void showCounter()
    {
        cout<<"Current : "<<Counter2<<" lines."<<endl;
    }
    static void showSum()
    {
        cout<<"In total : "<<sum2<<" lines."<<endl;
    }
    void readLine()
    {
        char s1,s2;
        double a1,b1,c,d;
        std::cin >> a1 >> s1 >> b1 >> c >> s2 >> d;
        gLine(a1,b1,c,d);
    }
};
int Point::Counter1;
int Point::sum1=0;
int Line::Counter2=0;
int Line::sum2=0;
 
int main()
{
    int num, i;
    Point p(1, -2), q(2, -1), t;
    t.showCounter();
    t.showSum();
    std::cin>>num;
    Line line[num + 1];
    for(i = 1; i <= num; i++)
    {
        Line *l1, l2;
        l1->showCounter();
        l1->showSum();
        l1 = new Line(p, q);
        line[i].readLine();
        p.showCounter();
        p.showSum();
        delete l1;
        l2.showCounter();
        l2.showSum();
        q.showCounter();
        q.showSum();
    }
    Line l1(p, q), l2(p,t), l3(q,t), l4(l1);
    Line::showCounter();
    Line::showSum();
    Point::showCounter();
    Point::showSum();
    Line *l = new Line[num];
    l4.showCounter();
    l4.showSum();
    delete[] l;
    t.showCounter();
    t.showSum();
}
 
/**************************************************************
    Problem: 1333
    User: 201701060928
    Language: C++
    Result: Accepted
    Time:28 ms
    Memory:1272 kb
****************************************************************/


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值