HDU - 5835

这题,数据真心不严.........

先贴题

Danganronpa

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1295    Accepted Submission(s): 819


Problem Description
Chisa Yukizome works as a teacher in the school. She prepares many gifts, which consist of  n  kinds with  a[i]  quantities of each kind, for her students and wants to hold a class meeting. Because of the busy work, she gives her gifts to the monitor, Chiaki Nanami. Due to the strange design of the school, the students' desks are in a row. Chiaki Nanami wants to arrange gifts like this:

1. Each table will be prepared for a mysterious gift and an ordinary gift.

2. In order to reflect the Chisa Yukizome's generosity, the kinds of the ordinary gift on the adjacent table must be different.

3. There are no limits for the mysterious gift.

4. The gift must be placed continuously.

She wants to know how many students can get gifts in accordance with her idea at most (Suppose the number of students are infinite). As the most important people of her, you are easy to solve it, aren't you?
 

Input
The first line of input contains an integer  T(T10)  indicating the number of test cases.

Each case contains one integer  n . The next line contains  n   (1n10)  numbers:  a1,a2,...,an (1ai100000) .
 

Output
For each test case, output one line containing “Case #x: y” (without quotes) , where x is the test case number (starting from 1) and y is the answer of Chiaki Nanami's question.
 

Sample Input
  
  
1 2 3 2
 

Sample Output
  
  
Case #1: 2
 

Author
UESTC
 

Source
 

Recommend
wange2014

先 贴一份神级代码(第一次写,年少无知,交上去自己都吓一跳)
#include<bits/stdc++.h>
using namespace std;
int s[100005];
int main()
{
    int a;
    cin>>a;
    for(int i=1;i<=a;i++)
    {
        printf("Case #%d: ",i);
        int n;
        cin>>n;
        for(int i=0; i<n; i++)
            cin>>s[i];
        sort(s,s+n);
        if(n==1)
            cout<<"1"<<endl;
        else
        {
            int sum=0;
            for(int i=0; i<n; i++)
            {
                sum+=s[i];
            }
            cout<<sum/2<<endl;
        }
    }
    return 0;
}
我真的交上去被吓到了......真的ac了,然后我当时处于对自己的怀疑(菜鸡本质,我查了题解)
然后我发现这题边界有点问题.......
先大概讲一下意思,以最大的那个去填坑,然后如果最大的太多了咋办?原本前面n-1的总量(sum)一字排开,现在我们插几个空,这样我们就可以把最大的那个穿插在里面.所以sum上面的坑,多出来的空,还有多出来的空的神秘礼物,3*sum,然后我们还可以+2,因为最前边还可以加两个最大,(假设我们是向右留的空,向左同理).
写到这我其实反应过来我+4的代码不对(嗯......),但是,也ac了??????
另外两份ac代码.......
#include<bits/stdc++.h>
using namespace std;
int s[100005];
int main()
{
    //freopen("in.txt","r",stdin);
    int a;
    cin>>a;
    for(int i=1;i<=a;i++)
    {
        printf("Case #%d: ",i);
        int n;
        cin>>n;
        for(int i=0; i<n; i++)
            cin>>s[i];
        sort(s,s+n);
        if(n==1)
            cout<<"1"<<endl;
        else
        {
            int sum=0;
            for(int i=0; i<n-1; i++)
            {
                sum+=s[i];
            }
            if(s[n-1]>3*sum+4)
                cout<<sum/2+2<<endl;
            else cout<<(sum+s[n-1])/2<<endl;
        }
    }
    return 0;
}


这个是+4的......

#include<bits/stdc++.h>
using namespace std;
int s[100005];
int main()
{
    //freopen("in.txt","r",stdin);
    int a;
    cin>>a;
    for(int i=1;i<=a;i++)
    {
        printf("Case #%d: ",i);
        int n;
        cin>>n;
        for(int i=0; i<n; i++)
            cin>>s[i];
        sort(s,s+n);
        if(n==1)
            cout<<"1"<<endl;
        else
        {
            int sum=0;
            for(int i=0; i<n-1; i++)
            {
                sum+=s[i];
            }
            if(s[n-1]>3*sum+2)
                cout<<sum/2+1<<endl;
            else cout<<(sum+s[n-1])/2<<endl;
        }
    }
    return 0;
}
琢磨了琢磨+2的对......(菜鸡本质,暴露无遗)



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值