数字排序

试题编号: 201503-2
试题名称: 数字排序
时间限制: 1.0s
内存限制: 256.0MB
问题描述:
问题描述
  给定n个整数,请统计出每个整数出现的次数,按出现次数从多到少的顺序输出。

输入格式
  输入的第一行包含一个整数n,表示给定数字的个数。
  第二行包含n个整数,相邻的整数之间用一个空格分隔,表示所给定的整数。

输出格式
  输出多行,每行包含两个整数,分别表示一个给定的整数和它出现的次数。按出现次数递减的顺序输出。如果两个整数出现的次数一样多,则先输出值较小的,然后输出值较大的。

样例输入
12
5 2 3 3 1 3 4 2 5 2 3 5
样例输出
3 4
2 3
5 3
1 1
4 1

评测用例规模与约定
  1 ≤ n ≤ 1000,给出的数都是不超过1000的非负整数。

代码:

#include<stdio.h>
#include<math.h>
#include<algorithm>
#include<string.h>
#include<iostream>
#include<iomanip>
#include<vector>
#include<map>
#include<set>
#include<stack>
#include<queue>
using namespace std;

bool cmp(pair<int,int> p1,pair<int,int> p2){
	if(p1.second != p2.second){
		return p1.second > p2.second;
	}else{
		rteurn p1.first < p2.first;
	}
	
}
int main()
{
	int n , number;
	map<int,int> mp;
	vector<pair<int,int>> vc;
	while(cin >> n){
		for(int i = 0 ; i < n ; i++){
			cin >> number;
			mp[number]++;
		}
		map<int,int>::iterator it = mp.begin();
		for(it ; it!=mp.end(); it++){
			vc.push_back(make_pair(it->first,it->second));
		}
		sort(vc.begin() , vc.end(),cmp);
		for(int i = 0 ; i < vc.size(); i++){
			cout << vc[i].first << " " << vc[i].second << endl;
		}
		vc.clear();
		mp.clear();
	}		
    return 0;
}

/* 测试用例 
12
5 2 3 3 1 3 4 2 5 2 3 5
*/
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值