Atcoder Beginner Contest 115 D

2 篇文章 0 订阅

D - Christmas
Time Limit: 2 sec / Memory Limit: 1024 MB

Score :
400
400 points

Problem Statement
In some other world, today is Christmas.

Mr. Takaha decides to make a multi-dimensional burger in his party. A level-
L burger (L is an integer greater than or equal to 0) is the following thing:
A level-0 burger is a patty.A level-LL burger (L≥1) is a bun, a level-(L−1) burger, a patty, another level-(L−1)(burger and another bun, stacked vertically in this order from the bottom.
For example, a level-1 burger and a level-2 burger look like BPPPB and BBPPPBPBPPPBB (rotated 9090 degrees), where B and P stands for a bun and a patty.
The burger Mr. Takaha will make is a level-
N
N burger. Lunlun the Dachshund will eat
X
X layers from the bottom of this burger (a layer is a patty or a bun). How many patties will she eat?

Constraints
1≤N≤50
1≤X≤( the total number of layers in a level-N
N and X are integers.
Input
Input is given from Standard Input in the following format:
N X
Output
Print the number of patties in the bottom-most
X layers from the bottom of a level-N burger.
Sample Input 1 Copy
Copy
2 7
Sample Output 1 Copy
Copy
4
There are
4
4 patties in the bottom-most
7
7 layers of a level-
2
2 burger (BBPPPBPBPPPBB).

Sample Input 2 Copy
Copy
1 1
Sample Output 2 Copy
Copy
0
The bottom-most layer of a level-
1
1 burger is a bun.

Sample Input 3 Copy
Copy
50 4321098765432109
Sample Output 3 Copy
Copy
2160549382716056
A level-50 burger is rather thick, to the extent that the number of its layers does not fit into a 32-bit integer.

题意:有一个这样的字符串
当i=0时,str[i]=“P”;
当i>0时,str[i]=‘B’+str[i-1]+‘P’+str[i-1]+‘B’;’
求当字符串为str[n]时,前x个有多少个p;
可以看出这是一个递归式,所以先用两个数组将str[1-n]的字符串长度和p的数量算出来。
接下来我们找规律,发现字符串是对称的,所以可以这样处理。
1.当x==str[i]时,答案就是算出来的ans[i];
2.当x<=str[i-1]+1,字符串是’B’+str[i-1];所以x–
3.如果都不是的话,字符串就是’B’+str[i-1]+‘P’,这个时候答案是ans[i-1]+2,x=x-str[i-1]+2;
所以只要一个for循环n-0就可以解决问题。
代码如下:

#include<bits/stdc++.h>
#define LL long long
#define Max 100005
#define Mod 1e9+7
const LL mod=1e9+7;
const LL inf=0x3f3f3f3f;
using namespace std;
int main()
{
	LL n,x;
	LL siz[52],eat[52];
	siz[0]=eat[0]=1;
	scanf("%lld%lld",&n,&x);
	LL ans=0;
	for(int i=1;i<=n;i++)
	{
		siz[i]=siz[i-1]*2+3;
		eat[i]=eat[i-1]*2+1;
	}
	for(int i=n;i>=0;i--)
	{
		if(x==0)
			break;
		if(x==siz[i])
		{
			ans+=eat[i];
			break;
		}
		if(x==1)
			break;
		if(x<=(siz[i-1]+1))
		{
			x--;
		}
		else
		{
			ans+=(eat[i-1]+1);
			x-=(siz[i-1]+2);
		}
	}
	printf("%lld\n",ans);
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值