K-th Number POJ - 2104 (主席树+离散化)

You are working for Macrohard company in data structures department. After failing your previous task about key insertion you were asked to write a new data structure that would be able to return quickly k-th order statistics in the array segment.
That is, given an array a[1…n] of different integer numbers, your program must answer a series of questions Q(i, j, k) in the form: “What would be the k-th number in a[i…j] segment, if this segment was sorted?”
For example, consider the array a = (1, 5, 2, 6, 3, 7, 4). Let the question be Q(2, 5, 3). The segment a[2…5] is (5, 2, 6, 3). If we sort this segment, we get (2, 3, 5, 6), the third number is 5, and therefore the answer to the question is 5.
Input
The first line of the input file contains n — the size of the array, and m — the number of questions to answer (1 <= n <= 100 000, 1 <= m <= 5 000).
The second line contains n different integer numbers not exceeding 10 9 by their absolute values — the array for which the answers should be given.
The following m lines contain question descriptions, each description consists of three numbers: i, j, and k (1 <= i <= j <= n, 1 <= k <= j - i + 1) and represents the question Q(i, j, k).
Output
For each question output the answer to it — the k-th number in sorted a[i…j] segment.
Sample Input
7 3
1 5 2 6 3 7 4
2 5 3
4 4 1
1 7 3
Sample Output
5
6
3
Hint
This problem has huge input,so please use c-style input(scanf,printf),or you may got time limit exceed.

题意:输入n个数,m次查询,每次查询区间l-r中第k小的数。

思路:如果直接暴力的话肯定会超时。所有需要优化,区间问题,第一个想到的优化,肯定是线段树,但是线段树只能维护整个区间(1-n),所以我们要用到主席树。

代码:
ps:我照抄别人的,才学主席树

//#include<bits/stdc++.h>
#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
#include<vector>
#define ULL unsigned long long
#define LL long long
#define Max 100005
#define mem(a,b) memset(a,b,sizeof(a));
#define pb push_back
#define mp make_pair
const LL mod=1e9+7;
const ULL base=131;
const LL LL_MAX=9223372036854775807;
using namespace std;
struct node
{
    int l,r,sum;
} tree[Max*20];
int a[Max];
int tot,root[Max];
vector<int>s;
int getid(int x) {
    return lower_bound(s.begin(),s.end(),x)-s.begin()+1;
}

void build(int &root,int l,int r) {
    root=++tot;
    tree[root].sum=0;
    if(l==r)
        return ;
    int mid=(l+r)/2;
    build(tree[root].l,l,mid);
    build(tree[root].r,mid+1,r);
}

inline void update(int l,int r,int &now,int last,int k) {
    tree[++tot]=tree[last];
    now=tot;
    tree[now].sum++;
    if(l==r)
        return ;
    int mid=(l+r)/2;
    if(k<=mid)
        update(l,mid,tree[now].l,tree[last].l,k);
    else
        update(mid+1,r,tree[now].r,tree[last].r,k);
}
inline int query(int l,int r,int x,int y,int k) {
    if(l==r)
        return l;
    int mid=(l+r)/2;
    int cnt=tree[tree[y].l].sum-tree[tree[x].l].sum;
    if(cnt>=k)
        return query(l,mid,tree[x].l,tree[y].l,k);
    else
        return query(mid+1,r,tree[x].r,tree[y].r,k-cnt);

}
int main()
{
    int n,m;
    while(scanf("%d%d",&n,&m)==2) {
        tot=0;
        s.clear();
        for(int i=1; i<=n; i++) {
            scanf("%d",&a[i]);
            s.push_back(a[i]);
        }
        sort(s.begin(),s.end());
        s.erase(unique(s.begin(),s.end()),s.end());
        build(root[0],1,n);
        for(int i=1; i<=n; i++) {
            update(1,n,root[i],root[i-1],getid(a[i]));
        }
        while(m--) {
            int x,y,k;
            scanf("%d%d%d",&x,&y,&k);
            printf("%d\n",s[query(1,n,root[x-1],root[y],k)-1]);
        }
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值