USACO Training 1.5 Arithmetic Progressions

An arithmetic progression is a sequence of the form a, a+b, a+2b, ..., a+nb where n=0, 1, 2, 3, ... . For this problem, a is a non-negative integer and b is a positive integer.

Write a program that finds all arithmetic progressions of length n in the set S of bisquares. The set of bisquares is defined as the set of all integers of the form p2 + q2 (where p and q are non-negative integers).

TIME LIMIT: 5 secs

PROGRAM NAME: ariprog

INPUT FORMAT

Line 1:N (3 <= N <= 25), the length of progressions for which to search
Line 2:M (1 <= M <= 250), an upper bound to limit the search to the bisquares with 0 <= p,q <= M.

SAMPLE INPUT (file ariprog.in)

5
7

OUTPUT FORMAT

If no sequence is found, a single line reading `NONE'. Otherwise, output one or more lines, each with two integers: the first element in a found sequence and the difference between consecutive elements in the same sequence. The lines should be ordered with smallest-difference sequences first and smallest starting number within those sequences first.

There will be no more than 10,000 sequences.

SAMPLE OUTPUT (file ariprog.out)

1 4
37 4
2 8
29 8
1 12
5 12
13 12
17 12
5 20
2 24
/*
ID: choiyin1
PROG: ariprog
LANG: C++
*/
 
#include <bits/stdc++.h>
 
using namespace std;
 
int main() {
    freopen("ariprog.in", "r", stdin);
    freopen("ariprog.out", "w", stdout);
    int n;
    int m;
    bool pq[127000] = {};
    cin >> n >> m;
    int squareNum = 0;
    for (int i = 0; i <= m; i ++){
        for (int j = i; j <= m; j ++){
            pq[i*i + j*j] = true;
        }
    }
    int step;
    int start;
    int maxInPq = m*m + m*m; 
    bool b = false;
    for (step = 1; step <= maxInPq; step ++){
        for (start = 0; start <= maxInPq; start ++){
            if (start + (n-1) * step > maxInPq)
                break;
            if (!pq[start])
                continue;
            int i, pos = start;
            for (i = 1; i < n && pq[pos]; i ++){
                pos += step;
            }
            if (i == n && pq[pos]){
                printf("%d %d\n", start, step);
                //cout << start << endl;
                b = true;
            }
        }
    }
    if (!b)
        cout << "NONE" << endl;
    return 0;
}

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值