USACO Training 1.6 Milk

Farmer John has three milking buckets of capacity A, B, and C liters. Each of the numbers A, B, and C is an integer from 1 through 20, inclusive. Initially, buckets A and B are empty while bucket C is full of milk. Sometimes, FJ pours milk from one bucket to another until the second bucket is filled or the first bucket is empty. Once begun, a pour must be completed, of course. Being thrifty, no milk may be tossed out.

Write a program to help FJ determine what amounts of milk he can leave in bucket C when he begins with three buckets as above, pours milk among the buckets for a while, and then notes that bucket A is empty.

PROGRAM NAME: milk3

INPUT FORMAT

A single line with the three integers A, B, and C.

SAMPLE INPUT (file milk3.in)

8 9 10

OUTPUT FORMAT

A single line with a sorted list of all the possible amounts of milk that can be in bucket C when bucket A is empty.

SAMPLE OUTPUT (file milk3.out)

1 2 8 9 10

SAMPLE INPUT (file milk3.in)

2 5 10

SAMPLE OUTPUT (file milk3.out)

5 6 7 8 9 10
/*
ID:choiyin1
LANG:C++
TASK:milk3
*/
#include<bits/stdc++.h>
using namespace std;int A,B,C;
bool vis[25][25][25],num[101],ok;
inline void dfs(register int a,register int b,register int c)
{
	if(vis[a][b][c]) return;
	vis[a][b][c]=true;if(!a)num[c]=true;
	int ca=A-a,cb=B-b,cc=C-c;//计算差值
	if(a>=cb) dfs(a-cb,B,c);
	else dfs(0,b+a,c);
	if(a>=cc) dfs(a-cc,b,C);
	else dfs(0,b,c+a);
	if(b>=ca) dfs(A,b-ca,c);
	else dfs(a+b,0,c);
	if(b>=cc) dfs(a,b-cc,C);
	else dfs(a,0,c+b);
	if(c>=ca) dfs(A,b,c-ca);
	else dfs(a+c,b,0);
	if(c>=cb) dfs(a,B,c-cb);
	else dfs(a,b+c,0);
	return;
}
signed main()
{
	freopen("milk3.in","r",stdin);
	freopen("milk3.out","w",stdout);
	scanf("%d%d%d",&A,&B,&C);
	dfs(0,0,C);
	for(register int i=0;i<=100;i++)
	if(num[i]) if(!ok) {printf("%d",i);ok=1;}else putchar(32),printf("%d",i);
	putchar(10);
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值