Candy
时间限制(C/C++):1000MS/3000MS 运行内存限制:65536KByte
总提交:21 测试通过:11
总提交:21 测试通过:11
描述
There are N children standing in a line. Each child is assigned a rating value.
You are giving candies to these children subjected to the following requirements:
(1) Each child must have at least one candy.
(2) Children with a higher rating get more candies than their neighbors.
What is the minimum candies you must give?
输入
The input consists of multiple test cases.
The first line of each test case has a number N, which indicates the number of students.
Then there are N students rating values, 1 <= N <= 300, 1 <= values <= 10000.
输出
The minimum number of candies you must give.
样例输入
5
1 2 3 4 5
5
1 3 5 3 6
样例输出
15
9
题目来源
BJFUACM
从前后两边找递增
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int a[305];
int dp1[305],dp2[305];
int main()
{
int n;
while(~scanf("%d",&n))
{
for(int i=0;i<n;i++)
{
scanf("%d",&a[i]);
}
memset(dp1,0,sizeof(dp1));
memset(dp2,0,sizeof(dp2));
dp1[0]=1;
for(int i=1;i<n;i++)
{
if(a[i]>a[i-1])
{
dp1[i]=dp1[i-1]+1;
}
else
{
dp1[i]=1;
}
}
dp2[n-1]=1;
for(int i=n-2;i>=0;i--)
{
if(a[i]>a[i+1])
{
dp2[i]=dp2[i+1]+1;
}
else
{
dp2[i]=1;
}
}
int ans=0;
for(int i=0;i<n;i++)
{
// printf("%d %d\n",dp1[i],dp2[i]);
ans+=max(dp1[i],dp2[i]);
}
printf("%d\n",ans);
}
}