hduoj 2143 box

box

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8574    Accepted Submission(s): 1830


Problem Description
One day, winnie received a box and a letter. In the letter, there are three integers and five operations(+,-,*,/,%). If one of the three integers can be calculated by the other two integers using any operations only once.. He can open that mysterious box. Or that box will never be open.
 

Input
The input contains several test cases.Each test case consists of three non-negative integers.
 

Output
If winnie can open that box.print "oh,lucky!".else print "what a pity!"
 

Sample Input
  
  
1 2 3
 

Sample Output
  
  
oh,lucky!
 

Author
kiki
 

Source




题意很简单,就是有细节问题会注意不到

a.b.c均为int型所以相加或相乘可能超int    要用long long
另外要注意 a%b时要先判定b!=0  不然提交就会出现RE的问题

判定了+就不用判定-,判定了*就不用判定/(题上/是除而不是取整)


#include<stdio.h>
int main()
{
  long long a,b,c;
  while(~scanf("%lld%lld%lld",&a,&b,&c))
  {
      int flag=0;
      if(a+b==c||a+c==b||b+c==a)
      {
          flag=1;
      }
      if(a*b==c||a*c==b||b*c==a)
      {
          flag=1;
      }
      if((b!=0&&a%b==c)||(c!=0&&a%c==b)||(c!=0&&b%c==a)||(a!=0&&b%a==c)||(b!=0&&c%b==a)||(a!=0&&c%a==b))
      {
          flag=1;
      }
      if(flag)
      {
          printf("oh,lucky!\n");
      }
      else
      {
          printf("what a pity!\n");
      }
  }
  return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值