【欧拉函数】 poj2407 Relatives(裸欧拉函数)

欧拉函数:对于一个正整数n,是小于或等于n的数中与n互质的数的数目,记作φ(n) 。

Euler函数表达通式:φ(x)=x*(1-1/p1)*(1-1/p2)*(1-1/p3)*(1-1/p4)…..(1-1/pn),其中p1, p2……pn为x的所有                   质因数,x是不为0的整数。φ(1)=1(唯一和1互质的数就是1本身)。

欧拉定理:对于互质的正整数a和n,有aφ(n) ≡ 1 mod n。

欧拉函数是积性函数:若m,n互质,φ(mn)=φ(m)φ(n)。

                    若n是质数p的k次幂,φ(n)=p^k-p^(k-1)=(p-1)p^(k-1),因为除了p的倍数外,其他数都跟n互质。

特殊性质:当n为奇数时,φ(2n)=φ(n),对于质数p,φ(p) = p - 1。注意φ(1)=1.

欧拉公式的延伸:小于或等于n的数中与n互质的数所有之和是φ(n)*n/2。

欧拉函数其它性质:

   设a为N的质因数,若(N % a == 0 && (N / a) % a == 0) 则有E(N)=E(N / a) * a;若(N % a == 0 && (N / a) % a != 0) 则有:E(N) = E(N / a) * (a - 1)。


欧拉函数的代码实现:

1.直接求解

int euler(int n)
{
    int cnt=n;
    for(int i=2; i<=sqrt(n); i++)
        if(n%i==0)
        {
            cnt-=cnt/i;
            while(n%i==0)
                n/=i;
        }
    if(n>1) cnt-=cnt/n;
    return cnt;
}
2.筛法求解

//筛选法打欧拉函数表
#define Max 1000001
int euler[Max];
void init()
{
    euler[1]=1;
    for(int i=2; i<Max; i++)
        euler[i]=i;
    for(int i=2; i<Max; i++)
        if(euler[i]==i)
            for(int j=i; j<Max; j+=i)
                euler[j]-=euler[j]/i;
}


poj2407  

Relatives
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 14019 Accepted: 7014

Description

Given n, a positive integer, how many positive integers less than n are relatively prime to n? Two integers a and b are relatively prime if there are no integers x > 1, y > 0, z > 0 such that a = xy and b = xz.

Input

There are several test cases. For each test case, standard input contains a line with n <= 1,000,000,000. A line containing 0 follows the last case.

Output

For each test case there should be single line of output answering the question posed above.

Sample Input

7
12
0

Sample Output

6
4
 
求euler(n)
#include<stdio.h>
#include<math.h>
int euler(int n)
{
    int cnt=n;
    int i;
    for(i=2; i<=sqrt(n); i++)
        if(n%i==0)
        {
            cnt-=cnt/i;
            while(n%i==0)
                n/=i;
        }
    if(n>1) cnt-=cnt/n;
    return cnt;
}
int main()
{
    int n;
    while(~scanf("%d",&n)&&n)
    {
        printf("%d\n",euler(n));
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值