pta查找指定字符

pta查找指定字符

本题要求编写程序,从给定字符串中查找某指定的字符。

输入格式:
输入的第一行是一个待查找的字符。第二行是一个以回车结束的非空字符串(不超过80个字符)。

输出格式:
如果找到,在一行内按照格式“index = 下标”输出该字符在字符串中所对应的最大下标(下标从0开始);否则输出"Not Found"。

输入样例1:

m
programming
结尾无空行

输出样例1:

index = 7
结尾无空行

输入样例2:

a
1234

输出样例2:

Not Found

#include <stdio.h>
#include <stdlib.h>

void search(char *pro, char ch, int length);

int main()
{
    char ch;
    char pro[81];
    int i = 0;

    scanf("%c", &ch);
    
    fflush(stdin);
    while ((pro[i] = getchar()) != '\n')
    {
        i++;
    }

    search(pro, ch, i);

    return 0;
}

void search(char *pro, char ch, int length)
{
    int i, max, flag = 0;

    for (i = 0; i < length; i++)
    {
        if (pro[i] == ch)
        {
            max = i;
            flag++;
        }
    }

    if (flag != 0)
    {
        printf("index = %d", max);

        exit(0);
    }
    else
    {
        printf("Not Found");
    }
}

fflush(stdin);

C语言:清空输入缓冲区的所有内容,在VS中没有效果

https://blog.csdn.net/cpp_learner/article/details/104178769

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Len1Mi

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值